Keras Network learner

Can anyone assist me with this, i keep getting WARN Keras Network Learner 3:6 failed to apply settings: Selected input columns do not provide enough elements (2) to populate all neurons (2304) of network input ‘input_1_0:0’. Try adding some columns to the selection.

Hi @xodox & welcome to the KNIME forum

This warning/error arises when the number of input columns specified in the -Keras Learner- node do not exactly correspond to the number of inputs set in your -Keras Input Layer- node or the number of columns available in your input data. For instance:

Here, the -Keras Input Layer- node has been configured to accept data made of 784 columns with “Float 32” data

For an input data which is made of 784 columns (starting with index 0 and ending with index 783) of type double (which is compatible with Keras Float 32 setting)

And then this has to be set in the same way in the Keras Network Learner as you can see in the next image

the Input_Layer_1_0:0 is recognized as having 784 input neurons and the type is a conversion type from Number (Double).

Hope this helps.

Best,

Ael

3 Likes

Thank you aworker, i have successfully gone pass that, i am experiencing a new error ERROR Keras Network Learner 3:6 Execute failed: Selected Keras back end ‘Keras (TensorFlow)’ is not available anymore. Please check your local installation.
Details: Installation test for Python back end ‘org.knime.dl.keras.tensorflow.core.DLKerasTensorFlowNetwork’ timed out. Please make sure your Python environment is properly set up and consider increasing the timeout (currently 25000 ms) using the VM option ‘-Dknime.dl.installationtesttimeout=’.

My pleasure @xodox. This is a different problem and I would just like to be sure whether a verified Keras workflow works (or not) with your Conda and Keras installation. Could you please for instance download and try the following KNIME workflow on your computer ?

If it doesn’t work, could you please post here the error you get in your KNIME console ?

Best

Ael

PS: Additionally to what I just wrote above, could you please check in your KNIME preferences that the Keras environment is set correctly (whatever the name you have given to it) ?

I have experienced sometimes that the DL configuration in KNIME gets unset when closing and opening KNIME again. Setting it back solved the problem for me.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.