KNIME 2.10 on MacOS does not work

Hi there,

I tried to install the new KNIME on my Mac (10.6.8). I've chosen the dmg-file without these free extensions and installation (on the Desktop) worked well. But then, if I want to start it, it quits unexpectedly after workspace selection (though I just left it's default value).

The same happens to my colleague.

I've attached the report from Mac.

I am also having a problem with an update install of 2.10 on the Mac.

It gets through the list of files to be updated but once it tries to install the updates it eventuially rolls back the update with the following error (from the log).

!ENTRY org.eclipse.equinox.p2.engine 4 4 2014-07-10 23:36:49.818
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2014-07-10 23:36:50.283
!MESSAGE session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.knime.binary.jre.macosx.cocoa.x86_64_root.cocoa.macosx.x86_64, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.ChmodAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.natives 4 0 2014-07-10 23:36:50.283
!MESSAGE The action chmod failed - file /Applications/knime/jre/Home/lib/server/libjvm.dylib does not exist

It seems to be looking for a library which (after looking at this location) is not there.

Seems that there are several install issues with this release that needs to be resolved,



It looks like the latest Java does not support MacOS 10.6 any more (if I remember correctly 10.6 itself is not supported by Apple any more). We can only test and support the latest MacOS version.

I was afraid of this answer.

Anyhow, it would be nice to have a little system requirement hint at the download section. Otherwise people do not know why their KNIME installation does not work.

Scott, can you describe in more detail how you got to the error message? The missing library is essential for the JRE, without it KNIME doesn't even start. So I'm wondering how it got lost in the first place.