KNIME 3.2: Issue/Bug in Tree Ensemble Learner Node: Missing option "Include all columns"

In addition to the bug in the Predictor Node also the Tree ensemble learner node lost the option (check box) "Include All Columns". This option was rather helpful when you have preprocessing steps like feature selection and hence you will not always have the same features. The updated learner node now has an issue when the features change (different columns):

WARN  Tree Ensemble Learner 0:390:377  Some selected attributes are not present in the input table: <list of columns>

The workflow then stops and does not continue and the node needs to be configured. Just opening configure dialog and closing it again works but it should work automatically like it did before.

Note that I have set the option to "Enforce Exclusion" and excluding 0 columns so it should always take all of them automatically. I don't need the old option but the node should just execute automatically even if input columns have changed. I also don't need a warning in that case. Best woud probably be throw warning but execute if columns have changed and if "Include All Columns" is checked, throw no warning.

Also doing a wildcard select with * causes the same issue. Tried that as a work-around.


Hello beginner_,

thanks for reporting the problem. We are aware of it and it will be fixed in the next version of the Analytics Platform.

However the old "include all" option will not return, but as You already pointed out correctly this will be equivalent to "Enforce Exclusion" with an empty exclusion list.

Once again sorry for the inconvenience.



Hi beginner,

we just published some minor bugfixes, including this one. If you update your KNIME Analytics Platform the loop support is enabled. (

Kind regards,


Thanks. Can confirm it works.