KNIME 3.5.1 Linux 64-bit GUI broken on Ubuntu 17.10

I had KNIME 3.4.x working just fine on Ubuntu 17.10.

I updated to KNIME 3.5.1 by downloading the new tarball, rather than using the in-app updater. (Unfortunately I deleted the directory and the tarball of the older 3.4 version when I updated.) The GUI has errors which make it unusable. Please see example screenshots.

The initial launch generates many instances of this error message:

    (KNIME:8945): GLib-CRITICAL **: g_base64_encode_step: assertion 'in != NULL' failed

and some other Gtk-CRITICAL and Gtk-WARNING messages. 

The "Extension installer" window crops out some buttons (OK, Cancel), though I can hit Return to select the default and continue the install. The installer seems to continue to complete, but then generates a segfault (I have core dumps disabled so there isn't one):

(KNIME:8945): Gtk-WARNING **: Negative content height -3 (allocation 1, extents 2x2) while allocating gadget (node toolbar, owner GtkToolbar)
Gdk-Message: Unable to load x_cursor from the cursor theme
Jan 22, 2018 6:37:54 PM org.apache.cxf.bus.osgi.CXFExtensionBundleListener unregister
INFO: Removing the extensions for bundle 118
1   0x7f22a39497c7 /usr/lib/x86_64-linux-gnu/ [0x7f22a39497c7]
2   0x7f22a898cbd1 /usr/lib/x86_64-linux-gnu/ [0x7f22a898cbd1]
3   0x7f22a89d2122 /usr/lib/x86_64-linux-gnu/ [0x7f22a89d2122]
4   0x7f22a89d25d9 /usr/lib/x86_64-linux-gnu/ [0x7f22a89d25d9]
5   0x7f22a8b89ab0 /usr/lib/x86_64-linux-gnu/ [0x7f22a8b89ab0]
6   0x7f232e29deb2 /usr/lib/x86_64-linux-gnu/ [0x7f232e29deb2]
7   0x7f2354387ec0 /lib/x86_64-linux-gnu/ [0x7f2354387ec0]
8   0x7f2354387f1a /lib/x86_64-linux-gnu/ [0x7f2354387f1a]
9   0x7f23539e28f7 /home/dwc62/Applications/knime_3.5.1/plugins/org.knime.binary.jre.linux.x86_64_1.8.0.152-01/jre/lib/amd64/server/ [0x7f23539e28f7]
10  0x7f2353e28bb5 /home/dwc62/Applications/knime_3.5.1/plugins/org.knime.binary.jre.linux.x86_64_1.8.0.152-01/jre/lib/amd64/server/ [0x7f2353e28bb5]
11  0x7f2353e26f7a /home/dwc62/Applications/knime_3.5.1/plugins/org.knime.binary.jre.linux.x86_64_1.8.0.152-01/jre/lib/amd64/server/ [0x7f2353e26f7a]
12  0x7f2353e272fe /home/dwc62/Applications/knime_3.5.1/plugins/org.knime.binary.jre.linux.x86_64_1.8.0.152-01/jre/lib/amd64/server/ [0x7f2353e272fe]
13  0x7f2353e27770 /home/dwc62/Applications/knime_3.5.1/plugins/org.knime.binary.jre.linux.x86_64_1.8.0.152-01/jre/lib/amd64/server/ [0x7f2353e27770]
14  0x7f2353c7d8d8 /home/dwc62/Applications/knime_3.5.1/plugins/org.knime.binary.jre.linux.x86_64_1.8.0.152-01/jre/lib/amd64/server/ [0x7f2353c7d8d8]
15  0x7f2354b4d7fc /lib/x86_64-linux-gnu/ [0x7f2354b4d7fc]
16  0x7f2354460b5f /lib/x86_64-linux-gnu/ [0x7f2354460b5f]
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f22a39497cc, pid=8945, tid=0x00007f233c2f2700
# JRE version: Java(TM) SE Runtime Environment (8.0_152-b16) (build 1.8.0_152-b16)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.152-b16 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  []  WTFCrash+0x1c
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# An error report file with more information is saved as:
# /home/dwc62/Applications/hs_err_pid8945.log
# If you would like to submit a bug report, please visit:

I tried also the nightly build knime_3.6.0_2018-01-22_21-20-08 and got the same behavior.


This is caused by in incompatibility between Eclipse and the GTK libraries that are shipped with Ubuntu 17.10. This can be resolved by either downgrading the GTK libraries to the previous version that worked or by an update to Eclipse. The latter we are looking into for the next release.

Hey hitthedeck,

as Thorsten said, there are a couple of issues with GTK and Eclipse on Ubuntu 17.10.
Additional to Thorsten’s solution, you can disable GTK3 by calling “export SWT_GTK3=0” before starting the Analytics Platform. See to get a more detailed explanation of that.
This does not perfectly fix the issue, but it’s a good workaround for the meantime.

Regarding the issue of window sizes being incorrect: We’re looking into that as well, but for the meantime maximizing the window makes all buttons mostly visible. If there is no button for maximization, under Ubuntu double-clicking the toolbar should do the trick.

Hope this helps and sorry for the inconveniences. If there are more problems, please let us know!