Knime 4.1.0 crashing on startup

Just installed Knime 4.1.0 (64 bit) on a new Linux Mint 19.2 install, (based on ubuntu 18.04) however I get “Segmentation fault (core dumped)” immediately on start-up. No log, no info in /tmp or install dir or my home login dir. It doesn’t appear to run long enough to leave a message.
Any other ideas on where to look or what to check? Very mysterious

Thanks,
Greg

Hi,
since KNIME is based on Eclipse, it might have to do with these two issues I found: one, two. Can you try to edit your Knime.ini file like people on the two linked websites described, i.e. changing the file path to Java? If that does not help, you could post your Knime.ini file here for us to have a look at it, if you don’t mind.
Kind regards
Alexander

2 Likes

Thanks, I tried replacing the line below -vm with the direct path to java but no change. I have openjava 11 installed, maybe I should also load openjava 8. Is knime OK with the open versions or do I need ‘real’ java from oracle? Unfortubately they are requiring and charging for licenses on java now. Need to lok at this some more.

– knime.ini –
-startup
plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
–launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.551.v20171108-1834
-vm
plugins/org.knime.binary.jre.linux.x86_64_1.8.0.202-b08/jre/bin
-vmargs
-server
-Dsun.java2d.d3d=false
-Dosgi.classloader.lock=classname
-XX:+UnlockDiagnosticVMOptions
-XX:+UnsyncloadClass
-XX:+UseG1GC
-Dsun.net.client.defaultReadTimeout=0
-XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot
-Xmx2048m
-Dorg.eclipse.swt.internal.gtk.disablePrinting

Hi,
as far as I know, we don’t Support OpenJDK 11 yet. Please try version 8. OpenJDK is definitely OK. You don’t need the Oracle-Java.
Kind regards
Alexander

1 Like

OK I sorted out my java version and now have openjdk-8 installed. When I enter…

$ java -version
openjdk version “1.8.0_232”
OpenJDK Runtime Environment (build 1.8.0_232-8u232-b09-0ubuntu1~18.04.1-b09)
OpenJDK 64-Bit Server VM (build 25.232-b09, mixed mode)

I edited my knime.ini file and replaced the line under -vm with
/usr/bin/java

knime still crashes

so I changed it to the full real path because Mint uses update-alternatives to manage java versions, ie.
/usr/lib/jvm/java-8-openjdk-amd64/bin/java

knime still crashes. It’s so strange, no logs or messages other than ‘Segmentation fault’ Any more ideas gratefully appreciated
Greg

Are you saying that if you launch KNIME from a terminal, you see just:

% knime
Segmentation fault (core dumped)
%

?

Quaeler, yes that’s what happens

and there is no file named core left behind? what does ulimit -c report?

No core file or logs that I can find. I’ve looked in the current dir, login dir, knime install dir… nothing new appears.
find . -name core in my home dir only finds ‘core’ named subdir’s in various packages, (like knime) but no core files

ulimit -c returns 0

Well there’s yer problem… 0 means “don’t allow core dumps” (or, alternatively, “allow core dumps but cap their size at 0 blocks.”)

Here’s a page telling you how to enable core dumps. Once you’ve got one, try compressing it and then attaching it to your reply.

After scouring the release notes and googling for info on coredump files on mint I discovered there is a function AND location for mint to write core dumps by “mintreport” in /tmp/mintreport/crash. In that directory I found a CoreDump file dated Jan 17, (last time I tried to run knime). When I check with ‘file CoreDump’ it tells me it’s a core file from running knime… so it’s attached in reduced size using ‘gzip -9’ but named as CoreDump-20200117.zip
Hope this works to figure out what’s going on.
CoreDump-20200117.zip (107.6 KB)

One more thing… There is a listing of “crash reports” and it includes the following text. The dir listed is where I have knime installed and it’s in my path so I do not know what it is talking about…

The package providing /home/greg/bin/knime_4.1.0/knime could not be found.
If you want to generate a stack trace for this crash report, please reinstall it.

Hmm… so the stack in the core:

Reading symbols from /home/loki/Downloads/knime_4.1.0/knime...done.
[New LWP 16991]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `knime'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x0000000000038250 in ?? ()
(gdb) bt
#0  0x0000000000038250 in ?? ()
#1  0x00007ff93074a733 in call_init (env=0x1fca890, argv=0x7ffe3da02948, argc=1, l=<optimized out>) at dl-init.c:72
#2  _dl_init (main_map=main_map@entry=0x1fb59e0, argc=1, argv=0x7ffe3da02948, env=0x1fca890) at dl-init.c:119
#3  0x00007ff93074f1ff in dl_open_worker (a=a@entry=0x7ffe3da02300) at dl-open.c:522
#4  0x00007ff93008d2df in __GI__dl_catch_exception (exception=exception@entry=0x7ffe3da022e0, operate=operate@entry=0x7ff93074edc0 <dl_open_worker>, args=args@entry=0x7ffe3da02300) at dl-error-skeleton.c:196
#5  0x00007ff93074e7ca in _dl_open (file=0x7ff92fa440ae "libgdk_pixbuf-2.0.so.0", mode=-2147483647, caller_dlopen=0x7ff92fa42e94 <loadGtk+1453>, nsid=<optimized out>, argc=1, argv=<optimized out>, env=0x1fca890) at dl-open.c:605
#6  0x00007ff930317f96 in dlopen_doit (a=a@entry=0x7ffe3da02530) at dlopen.c:66
#7  0x00007ff93008d2df in __GI__dl_catch_exception (exception=exception@entry=0x7ffe3da024d0, operate=operate@entry=0x7ff930317f40 <dlopen_doit>, args=args@entry=0x7ffe3da02530) at dl-error-skeleton.c:196
#8  0x00007ff93008d36f in __GI__dl_catch_error (objname=objname@entry=0x1fb17d0, errstring=errstring@entry=0x1fb17d8, mallocedp=mallocedp@entry=0x1fb17c8, operate=operate@entry=0x7ff930317f40 <dlopen_doit>, 
    args=args@entry=0x7ffe3da02530) at dl-error-skeleton.c:215
#9  0x00007ff930318735 in _dlerror_run (operate=operate@entry=0x7ff930317f40 <dlopen_doit>, args=args@entry=0x7ffe3da02530) at dlerror.c:162
#10 0x00007ff930318051 in __dlopen (file=<optimized out>, mode=<optimized out>) at dlopen.c:87
#11 0x00007ff92fa42e94 in loadGtk () at eclipseGtkInit.c:207
#12 0x00007ff92fa4266e in initWindowSystem (pArgc=0x7ffe3da0271c, argv=0x1fafd50, showSplash=1) at eclipseGtkCommon.c:73
#13 0x00007ff92fa39b77 in _run (argc=1, argv=0x1fafd50, vmArgs=0x1fb24e0) at ../eclipse.c:629
#14 0x00007ff92fa395cc in run (argc=1, argv=0x1fafd50, vmArgs=0x0) at ../eclipse.c:476
#15 0x000000000040163e in main (argc=7, argv=0x1fafd50) at ../eclipseMain.c:217
(gdb) 

shows that it is seg-faulting during the GTK initialization.

Unfortunately (or fortunately), 4.1.0 runs fine for me on Mint 19.2 - so it doesn’t appear to be something strictly related to the OS install. Have you changed the window manager from something other than what gets used by the out-of-the-box install of 19.2? Done any other changes to the configuration of the window system since installing 19.2?

2 Likes

No changes to the window manager, always gnome/MATE, just modifying backgrounds and adding apps to the menu bar across the bottom. Could GTK need refreshing? how to do that? reinstall? probably a million dependencies. I also see a notice on login that I should/could upgrade to mint 19.3, wonder if that would help?
Greg

Hmm… my Mint installed with Cinnamon (as seen in the screen shot above.)

(I just downloaded the ISO and installed the OS for this forum thread - so it really is pretty vanilla.)

Maybe try using Cinnamon instead?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.