Knime 4.2.1 doesn't works with server 4.11.1

Hi All,

In my company we have just upgraded KNIME analytics platform to version 4.2.1, and our server version is 4.11.1

When we try to run our workflows on the server we received the following error:

One possible solution is downgrade KNIME analytics platform to version 4.2.0 and apparently everything works fine, but we want to understand why does this happened and how to fix it, before giving up on version version 4.2.1 forever.

So do you have any suggestion of what is going on?

Best regards

Did you upgrade the KNIME server executor?

Hi @AR7

that is because of a most recent hotfix bugfix of ours.

Can you update your KNIME Servers Executor? You will need to restart the executor service afterwards.
Than those workflows will be accepted again.

Alternatively you can change a parameter on the KNIME Server. By enabling the following setting to false you will allow the server to try loading all workflows, irrespective of the server version.

(You can find this documented here as well:

Best, Iris

1 Like

Hello Iris,

Thank you very much for your help.
We had tried many thing and nothing had been working.

Hopefully your solution has worked. Apparently everything is working just fine.

Thank you,
Best regards


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.