KNIME 4.2 and Microsoft SQL Server 2019


I now have version 4.2 in the hope that the current driver for the MS-SQL Server 2019 would be integrated.
But apparently this is not the case, because the problem see link continues.

Then I set up the driver myself as described in the following link.

But this doesn’t work either.

I have a huge respect for open source, but it is always the same when you use the SQL server there are only problems.
I have no idea how to get KNIME going. I had expected the drivers to be delivered with the new update. Especially since my first post is from May 2020.

Hello @PatrikS,

if I got you right you still haven’t managed to connect KNIME to your database? Sry to hear that. Judging from second topic you tried to register driver that supports SQL Server 2019? Have you done that? If so where did it go wrong when you tried to connect to database?



on advice I have integrated the driver for jre 8.x.

Then changed the settings in the node.

If I run Exceute I get the following error message.

ERROR Microsoft SQL Server Connector 0:51 Execute failed: Fehler beim Herstellen der TCP/IP-Verbindung mit dem Host ‘W11D1’, Port 1433. Fehler: ‘Socket operation on nonsocket: configureBlocking. Überprüfen Sie die Verbindungseigenschaften. Stellen Sie sicher, dass eine SQL Server-Instanz auf dem Host ausgeführt wird und am Port TCP/IP-Verbindungen akzeptiert. Vergewissern Sie sich, dass am Port keine TCP-Verbindungen durch eine Firewall blockiert werden.’.

Everything that is described here cannot be the cause. I am currently working on the SQL Server with ArcGIS, ArcPy (Python), Access and Statistica.


Hello Patrick,

Thank you for continuing to work through this issue with us.

You mentioned “Everything that is described here cannot be the cause”, but we need to follow the Sherlock Holmes method and methodically disprove each thing separately to arrive at what must be the truth.

Possible causes that come to mind include:

  • need to use FQDN for hostname
  • port is incorrect
  • authentication is failing or incorrectly configured
  • [Error: 'Socket operation on nonsocket: configureBlocking] may indicate the socket is getting interrupted/closed unexpectedly.
  • firewall blocking the port from the client

Of these, it seems the first may be the easiest to test; is it possible to change how the server is being referenced to explicitly designate the host?

Thank you,

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.