KNIME 4.7 creation of DL environment fails

Hi, I’m currently testing your nightly build version of KNIME 4.7 and it seems, that the build-in creation of DL envs fails - see attachment. (pointing to Miniconda)
Having Miniconda3 installed, I have no problem with it outside of KNIIME.
Best
Erich

@Erich_Gstrein

Have you tried this again with Conda installed? It could be that KNIME can’t find the executables that it is looking for, in the places that it expects to find them.

I switched to using Mamba instead of Conda which created all sorts of problems with KNIME, as KNIME assumes that executables will be in specific locations (at least on Windows that is the case). As my mamba installation was in a non-typical location I added a hard-junction (alias/shortcut) between a folder where KNIME expected Conda to be installed and the installation location of Mamba. This worked, though more a sticking plaster solution than something I want to leave in place long term.

DiaAzul

Hi @Erich_Gstrein,

Did you configure Conda properly in the Conda preference page?

If so, could it be that you are using a very recent version? We have seen these SSL errors with very recent versions of conda / anaconda. Please see Unable to integrate python with Knime for a suggested fix.

Does that help?
Carsten

Thx Carsten, switching to conda 4.14 solved my problem!
Erich

2 Likes