KNIME AI Extension (Labs) nodes not found on v5.1.2 after installation

I’ve installed the KNIME AI Extension (Labs) nodes on v5.1.2. The KNIME AI Assistant comes up and works, but all the other included nodes are not available and Knime will try to install them again even though the extension is installed. I’ve tried uninstalling and reinstalling the AI extension with the same result. Is there another prerequisite I’m missing to be able to use these AI nodes?

Here is the error. An error occurred while installing the items
session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null → [R], action=org.knime.product.p2.actions.ShellExec).
ShellExec command exited non-zero exit value:

Hey @benpope, could you please provide the full installation error logs? You can find them as described here: KNIME Python Integration Guide


1 Like

Thanks for the reply Alex. There is nothing in the create_env.err log file. In the create_env.out log summary it shows install 195 packages and total download 0b. So that looks to be the problem.

Is the issue that I need to install and configure my local Python environment to be able to use these AI nodes or is the AI extension self-contained and just not installing as expected?

The AI extension should install the Python environment for you, so this is not expected. Can you paste the contents of the create_env.out file here please?

Dear @benpope,

additionally to Carstens question to rename the create_env.out to a .txt file and post it here, I would like you to enable long paths: KNIME Python Integration Guide

Following the links, the following procedure is described:

This registry key can also be controlled via Group Policy at Computer Configuration > Administrative Templates > System > Filesystem > Enable Win32 long paths.

In there you can set it to 1, please do so and then uninstall and install the AI Extension again.

Furthermore I am not sure whether the download of 0b is the issue, I think the download of the necessary packages already happened during the first installation try.

Best regards

Thanks for the replies. I verified that long paths were enabled in my Win11 systems, then uninstalled and reinstalled the AI Extension. I had the same result that the AI assistant is there and works, but all the other AI related nodes in the extension are missing.
Log file uploaded.
create_env_out.txt (36.3 KB)

Dear @benpope,

thanks for verifying, testing and the details!

A side note: the AI Assistant is a different extension and independent from the AI Extension. The AI assistant is Java based and this issue is related to installing a Python environment for the Python based AI Extension, unfortunately.

As the easier things did not work, we will dig deeper: could you please have a look at the knime log and see whether there is something interesting there and post it?

Maybe @carstenhaubold or @Alex_JW have additional thoughts.

Best regards

1 Like

Let’s see if today’s Knime log helps Steffen. I’m keen to try those Azure AI nodes I saw in the demo today. I also tried uninstall/install running as Admin with the same result.
2023-10-26 Knime Log.txt (161.8 KB)

Hey Ben,

sorry for all the troubles.

The interesting part there seems to be

2023-10-26 12:39:35,924 : ERROR : Worker-0: Node Repository Loader : : PurePythonNodeSetFactory : : : Failed to parse Python node extension at path ‘C:\Program Files\KNIME-5.1\configuration\org.eclipse.osgi\861\0.cp\src\main\python’.
Cannot invoke “org.knime.conda.envbundling.environment.CondaEnvironment.getPath()” because “environment” is null

However, no further details about the installation itself. Could you try to install KNIME Nodes for Scikit-Learn (sklearn) Algorithms – KNIME Community Hub and KNIME Python Integration – KNIME Community Hub ? Do they work?

Besides, are you maybe sitting behind some proxy such that the download of the Python modules does not work?




No trouble and appreciate the help.
The Python Intergration nodes were there and can be selected out to the canvas, but I’m getting this error when trying to run them.>
Could not start Python. There are problems with your Python environment:
Could not start Python executable at the given location (C:\Knime\Python\PyStart.bat): Cannot run program “C:\Knime\Python\PyStart.bat”: CreateProcess error=2, The system cannot find the file specified
I checked my preferences Python setting and it was set to manual to point to an old Python installation that does not exist anymore. I changed that to the bundled option. I then added the Skleran extension and restarted Knime. All the Sklearn nodes are available, and they will run. Still getting Python errors when I try to run the Python nodes. “Path to python executable is not set. Please configure under Preferences > KNIME > Python Scripting.” I then tried a complete uninstall reinstall of Knime 5.1.2 with the same result. I suspect the overall issue is how my Python environment is, or is not, set up.

Hi @benpope,

thanks for further investigating the issue and outlining the intermediate steps.
It seems that we look at three different topics now:

  1. sklearn extension: is working now, correct?
  2. KNIME AI Extension (Labs): is that one also working now?
  3. Python Script nodes: not working. You say, that in Preferences -> KNIME -> Python the radio button is set to bundled (and not to Conda or Manual), correct? This is interesting. Would you mind sending screenshots of Preferences -> KNIME -> Python and a screenshot of your workflow and lastly a screenshot of the error again? Furthermore, you could try in the mentioned Python preferences to click on Create New Environment... to create a new environment and use that one in the Python nodes, maybe that works and somehow the bundled environment got messed up?

Best regards

1 Like

Sklearn nodes are accessible and can run. The AI extension are installed but the nodes are not accessible and show as missing. Python is a mixed result. Some nodes run and some nodes are throwing a path to Python is not executable error.
Python is set to bundled under preferences. I still need to test switching to Conda and setting up my own environment.

Thanks for your help on this,

Dear @benpope,

thanks for the thorough details. We are still investigating (@carstenhaubold wanted to have a look whether he can reproduce on a Windows machine).

@benpope some posts ago I asked:

are you maybe sitting behind some proxy such that the download of the Python modules does not work?

Is that the case maybe?

About the Python Plot node (seems to be the only one failing in that screenshot): it is not from our extension Python Integration, but from KNIME Python Scripting Extension, which is a community extension (yeah, confusing, I know). I suggest just using Python Script node and Python View node.

I hope we can reproduce this somehow. Sorry that we cannot provide an immediate solution.

Best regards

1 Like

Glad I can help on at least identify and debugging an issue. I’m one of the early adapters and Knime SME’s here at GM, so I expect I’ll need to be able to help out internal community out with this as well once we get it resolved. It is an odd issue, but I typically don’t use Python much in my day-to-day work.

I do have proxies set as these are necessary to install any extensions. I don’t think they block Python as I have installed and used Python nodes in earlier versions of Knime. Right now, I do not have a separate instance of Python installed on the current PC. I was thinking that Knime would install and use the needed Python bits if the bundled option was selected. I’ll try installing Conda and switching to that option.


I did a test by installing v5.1.2 on my personal computer and found that I could install the AI extensions. At this point, I’m thinking that something in the work environment polices, or settings are blocking the AI Extensions installation. We do use a proxy in our network connection settings and a VPN in order to get outside the workplace firewall and download any extensions. Wondering if there is something unique about the AI Extensions that needs different setting or perhaps white listing. Any suggestions?

Hi @benpope,

with other Python extensions, do you mean Geospatial or sklearn? Could you give Geospatial a try to see whether the issue applies to Python environments in general or just the KNIME AI Extension?

To summarize:

  • you try to install the KNIME AI Extension (Labs), but it always fails with the message in the first post

  • you verified that Windows long paths are enabled

  • you tried installing the KNIME AI Extension as admin

  • the create_env.out of KNIME AI Extension does not provide insights, it just stops with

    Install: 195 packages
    Total download: 0 B
    Transaction starting
  • the creat_env.err of KNIME AI Extension does not exist or is empty

  • Python Integration is working

  • sklearn is working (which uses the same environment as Python Integration)

  • we do not know whether other Python nodes are working - examples are: Geospatial, Apprise, Redfield BERT, Redfield NLP Nodes; maybe you can give them a try to locate the issue more specifically? That would be helpful!

If it is a Proxy issue, then we would need to wait until KNIME Analytics Platform 5.2.
Maybe @carstenhaubold or @nemad have any other thoughts?

Sorry for the troubles

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.