Knime analytical platform 4.1.3a crashes during the loading of workflow

Hi, I have just updated the knime analytic platform to 4.1.3a. I have a fairly heavy proteomics workflow which, loaded fine in an earlier version. However with 4.1.3, this workflow starts to load but the platform crashes during the process. Other workflows load fine. I have reloaded the workflow that causes the crash just in case it had become corrupted somehow, but with the same result.
Could this be problems with memory? I only have 8 Gb on my laptop.

Thanks for any feedback


Hello @0nly4phil,

you updated to 4.1.3 from which version? What extensions does workflow need in order to run? Can you maybe share workflow?

Additionally you can check your log files. Please make sure to put log level to DEBUG.
(This is done within KNIME if you go File --> Preferences --> KNIME)

Here is location of log files to check after crash occurs:

  • ...\knime-workspace\.metadata\knime\knime.log
  • ...\knime-workspace\.metadata\.log

If sharing logs here please make sure to exclude sensitive data, if any.



Hi Ivan. Thanks for your reply.
The update was from 3.7.2.
I checked both log files and there was nothing reported from the time of the crash (last entries were from before the crash).
Unfortunately, the workflow is in a folder with subfolders and cannot be uploaded here. However, using 3.7.2a, the workflow loads but some components require the later image version and dont execute.



Hello @0nly4phil,

have you changed log level to DEBUG? The first log should have entries about workflow opening. Something like this:

2021-08-09 11:28:16,874 : DEBUG : main : : WorkflowEditor : : : Creating WorkflowEditor…
2021-08-09 11:28:16,875 : DEBUG : main : : WorkflowEditor : : : creating editor actions…
2021-08-09 11:28:16,876 : DEBUG : main : : WorkflowEditor : : : Initializing editor UI…
2021-08-09 11:28:16,876 : DEBUG : main : : WorkflowEditor : : : Opening workflow Editor on workflow.knime
2021-08-09 11:28:16,876 : DEBUG : main : : WorkflowEditor : : : Setting input into editor…
2021-08-09 11:28:16,877 : DEBUG : main : : WorkflowEditor : : : Resource File’s project: file:/C:/Users/…

Does it crashes immediately after trying to open it or after some time?

Is workflow related to image processing and is it in state reset or saved with data. If saved with data can you reset it under 3.7.2 and then give it a try in 4.1.3?


Hi Ivan,
it crashes about half way through loading.
Yes it does involve some fairly intense and numerous plot graphics.
This morning I tried loading the workflow without the processed data and it loaded fine.

Many thanks for your suggestion!

1 Like

Hello @0nly4phil,

seems is related to memory after all. Maybe you can increase assigned memory in knime.ini for future work. Anyways glad you found a way to load your workflow!


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.