KNIME and Ubuntu 9.10

After installation of the Ubuntu 9.10 I download fresh version of the KNIME 2.1.0 for x86_64. At first, I see warn: “The operating systems web browser could not be found! Using fall back (text-only) browser” in the help window.
And I cann’t load any extensions - I checked them, push “Install” button and have nothing. Without any warnings.
Can I solve this problems any way?
Thank you!

Oh, very interesting… When I push “Install” by the left mouse button, it don’t work, it only select. But when I press Enter key, I push button.

Hi, Max

for the “push button and nothing happens”-problem: this is a bug in eclipse, but the workaround with hitting enter or the shortcut should work fine.

For the problem with the help browser, I had the same issues (in the same configuration), installing xulrunner-1.9.1 (the is the package name) resolved the problem for me:

type on the terminal:

sudo apt-get install xulrunner-1.9.1

hope this helps

Hi Uwe,

this xulrunner thing did not fix the bug for me…
the workaround for the “push button and nothing happens problem” dit it quite well though…


Hi Uwe,
Thank you, but problem, possibly, not in xulrunner. I have installed the latest version of xulrunner, but problem is not fixed.

I’m not sure, what uwe actually did, but my latest information is that it does not work with any xulrunner > 1.9.0.x. Therefore you need to install an older xulrunner < 1.9.1. This is a problem with Eclipse 3.4, they seem to have the same problem over and over again with any new release of xulrunner and no patches for older Eclipse versions are provided :frowning:

Thank you, Thor, I try to do this.

hey max,

i run in the same problem and reading following thread helped:

also i adjusted the proposed script solution like this:



I use KNIME 2.1.1 and Ubuntu 9.10. To get it working I did the following:

  1. Ran the command “sudo apt-get install xulrunner”. This installs xulrunner version 1.8.1. It will happily coexist with xulrunner-1.9.1 (the default for Ubuntu 9.10). NOTE: this package is in the “universe” repository, so make sure “universe” is enabled.

  2. I added the following line to the bottom of the file knime.ini: “-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner”. Don’t include the quotes though :slight_smile:

Hope that helps,

Arthur, thank you very much. It’s work fine!

I ran into the same problems.

I use KNIME 2.1.2 and OpenSUSE 11.2 64 bit.
To get it working I had to do the following:

  1. First the repository for OpenSUSE 11.1 had to be added as the 11.2 repository doesn’t provide versions before xulrunner-1.9.1

  2. Get the xulrunner version with yast (GUI) or sudo zypper install mozilla-xulrunner-

  3. Add the following line to the bottom of the file knime.ini (eclipse.ini): -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner-1.9

Hope I can save someone the time I needed,

I am using Ubuntu 10.04 and adding -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner to my knime.ini worked for me. No other changes required.
Thanks for sharing the knowledge.

Hi all,

Apologies for the thread necromancy, but I have run into the same problem and have tried dealing with xulrunner.

I'm using Ubuntu 12.04, which from what I gather removed xulrunner from its package list, meaning that I've had to install it "manually" (using this guide - )

Though, after installing it (Firefox 14.0.1), creating the symbolic links and then adding the relevant line to the eclipse.ini file for the KNIME SDK, I still have the same problem.  I've also tried pointing it to xulrunner-bin instead of but no luck (the .sh file in FireFox 14.0.1 seems to give errors about missing the mozilla run directory, though I have not managed to update FireFox yet).

Pointers would be greatly appreciated :)


Thanks in advance,



No worries, a colleage informed me that you can download the old binaries for XULRunner via the Eclipse/KNIME update portal.  Works fine now.

<br />

EDIT:  Looks like thor beat me to it, ty :)