KNIME AP not responding

Hi Team,

I am trying to upload the data to Microsoft SQL Server DB using DB Writer node and tried with DB Insert Node also which is 4K records of data.
It is turning into not responding state like below.

Please help me in resolving the issue.

Please let me know for further information.

Thanks,
Subramanyam Kinthada.

Hi Team,

Please suggest me any solution.

@Subramanyam have you considered doing it in chunks?

Hi @mlauber71,

Yes, I have tried it with 1K records but the same issue repeated.

@Subramanyam does this work at all? Have you tried just a few lines maybe. Is there any response or anything in the Log file?

well, its working with less than 400 records. but not working for more than that limit.

@Subramanyam it might work to use a loop and only send that amount in one go. Or you could check if there are settings limiting the intake of the server.

Or you could try and adapt the BATCHSIZE in the driver connecting to the server. Could look like this:

1 Like

Hi @mlauber71

I have tried the above settings. the node got failed and KNIME AP changed to not responding state.