Knime Batch Execution - Java exit code 4 - No error in log

I am trying to run a workflow in batch mode… which runs fine without any issues in foreground mode.

I am passing workflow variables in batch execution… I don’t see any errors in console log.


Can someone please guide me what I am doing wrong here. The workflow variables are defined at the workflow level.

Hi @jaydeep1 , I can’t see the full value of the -workflowDir as you obfuscated it. Can you confirm if it’s pointing to the workflow’s folder or to the workflow file?

It’s pointing to the Worflow folder…

Hi @jaydeep1 , there’s not much info to go by…

Command line seems to be ok, and no error message.

I see warnings about the SOAPRequest. I know we can get this type of warnings at the beginning of the workflow as data has not been processed yet, but I am assuming that eventually in the workflow, the required Input tables are provided? And it’s double-checked?

Yes - I get Soaprequest warning in GUI mode too… but that is resolved because it’s created at the run time… what additional information can I provide? I am puzzled. :grinning:

Hi @jaydeep1 , I’m not sure what additional info you an provide… I’m as puzzled too, because there’s no error messages.

Hopefully we can get some input from others.

I tried running again and now showing this error in log

2021-08-26 19:08:27,589 : ERROR : Clear OSGi configuration :  : InvokeUpdateAction :  :  : Could not clean OSGi configuration area: C:\Program Files\KNIME\configuration\org.eclipse.osgi\360\0\.cp\os\win32\x86_64\localfile_1_0_0.dll

I ran without workflow variables this time - because the global variables have default values set in the workflow when not set explicitly…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.