KNIME broken after Ubuntu partial update

Knime doesn’t work properly and I can’t do anything with my work flows after the latest update on Ubuntu 18.04 my work laptop.
Any hints how to fix this?

Could you be more specific in what you mean by “can’t do anything with my workflows”?

I open a WF and I can’t select, move, right-click or anything else on it. That must be some backend OS ingredient which influences all this, but I don’t know what. I can share the current OS version, if that may help.

Yep that would be helpful. What window manager are you using?

Another question. Do you see the same problem with a fresh knime installation?

It reads Ubuntu 18.04.4 LTS, GNOME 3.28.2 (64 bit).
Apparently, KNIME only has portable version for Linux, and yes, I tried temoving it completely, then extracting again.

I tried creating a whole new WF, I successfully dragged two nodes, but I couldn’t do anything more with them. Saved the wf… now I can’t even open it. Interesting is that even the program icon doesn’t appear anymore.

This seems to be a general issue. I deleted everything related to KNIME, then extracted the zip again, run it and you can see that there’s neither a wf tab title, nor this upper-left node is in its original placement.
Seems like some graphical framework is totally corrupted, but everything else on my laptop works just fine. :confused: