KNIME Core Extension Nodes missing with version 3.6.2 update

I recently updated to version 3.6.2 and now as a side effect I am missing KNIME Core Extension nodes such as String Manipulation (and a few others).

In my console I see errors including:

ERROR RepositoryManager Node org.knime.base.node.jsnippet.JavaSnippetNodeFactory’ from plugin ‘org.knime.jsnippets’ could not be created: Can’t load factory class for node: org.knime.base.node.jsnippet.JavaSnippetNodeFactory The corresponding plugin bundle could not be activated!

as well as:

ERROR LoadWorkflowRunnable Status: Error: Node “String Manipulation” not available from extension “KNIME Core” (provided by “KNIME AG, Zurich, Switzerland”; plugin “org.knime.jsnippets” is installed)

I’ve tried uninstalling and reinstalling the KNIME Core Extension, but this has not worked. KNIME cannot fully uninstall the Core extension since other software apparently relies on it.

And each time I get the error the KNIME Core Extension is missing, I get a prompt to install but then I get a message that it is already installed.

Any help would be appreciated! Thanks.

1 Like

Have you tried restarting KNIME with the -clean parameter set?


best,
Gabriel

I opened up my command prompt and tried the above but i keep getting an error that it is not a recognized internal or external command.

Could you be more specific in the steps i need to take to do this? I might be missing something that I should be typing in. Thanks!

edit: so I ran the following in the command prompt:

cd C:\Program Files\KNIME
knime -clean

This launched knime but i’m still getting the same error. Did i do something wrong?

1 Like

No this was exactly what I wanted you to test, it looks like the update broke your KNIME installation, you will need to reinstall it.

best,
Gabriel

Ok. Should I reinstall the most updated version? Or should I attempt to reinstall the previous version of KNIME to prevent this error.

Hi @phelias92,

Before reinstalling, can you quickly provide the KNIME log file of the broken installation? Also, did you install a nightly build or similar previously in the same installation?

Best,

Christian

@christian.dietz my error log is attached. If you scroll to the bottom to the errors for November, you’ll see the errors related to the update. I had updated on 2018-11-10. You can probably ignore any errors before that as those were not related to the update.

And I don’t think I installed any nightly build (actually not 100% sure what that means).

Let me know if you need anything else.
knime_error_log.log (833.9 KB)

We’re on it. However, if you want to proceed you can reinstall 3.6.2 from the scratch and then it should work. Just make sure you use the same workspace as before and your workflows won’t be lost.

Sorry for the trouble and thanks for the log!

Christian

Ok i’ll do that. should i uninstall first or just redownload and let it overwrite? @christian.dietz

I think uninstall first. just make sure you save your workspace before… just to be sure.

Just want to let you know that I am having the same problem. After updating Knime from 3.6.0 to 3.6.2 and loading a large workflow it complains about missing extensions: String Manipulation, Rule-based Row Splitter, Java Snippet, Python Plot. Removing and reinstalling Knime does not solve the problem. I can also no longer find these nodes in the repository. Also the UI looks funny. I am running Knime in a Xubuntu 18.04 VM.

Sorry to hear that. In order to debug your problems could you provide us a screenshot of the “funny UI” and your knime.log? Also, did you change the underlying Java version KNIME is using (if you did nothing, then you didn’t change it ;-)).

In the attachment the log file and a screenshot. Also, I have investigated the situation a bit more. I have been specifically following the Rule-Based Row Splitter node as I install the KNIME extensions that my workflow requires. It turns out that the Rule-Based Row Splitter (and also the String Manipulation and Java Snippet nodes) disappear specifically when I install the KNIME Image Processing extension. All the other extensions that I use do not seem to cause problems. Could there be something wrong with the newest version of the Image Processing extension? @phelias92 , do you by chance happen to use the Image Processing extension as well?

As for the the Java version problem that you mention, searching the KNIME FAQ and Googling did not help. What version of Java should I be using for Knime and how do I change this?

knime.log (3.8 MB)

2 Likes

Two more observations:

  • When I remove the Image Processing extension, the Rule-Based Row Splitter and the other missing nodes reappear
  • Installing an older version of the Image Processing extension (1.7.0.201810300545 instead of …650) does not solve the problem
1 Like

Hi @Aswin,
thank you very much for your investigations, I was able to reproduce the issue and we are working on fixing it. If you need to use Image Processing right now, you can use the nightly build: https://www.knime.com/wiki/knime-image-processing-nightly-build

best,
Gabriel

1 Like

@gab1one , thank you for working on a fix! Greatly appreciated. @christian.dietz , the UI problem was totally unrelated and caused by myself by not inserting the launcher.GTK_version=2 in the knime.ini file of the new installation. I somehow thought that this was no longer necessary, but obviously I was wrong. Sorry about that.