KNIME crashes when table with RDKit molecule type is inspected

Hi guys,
I’m experiencing a serious problem when working with RDKit nodes. When I try to simply inspect the output table of RDKit From Molecule node the window opens and then suddenly, before seeing any data, the entire KNIME abruptly crashes.
I upload here a very simple workflow where this happens.
I realized that I can keep working with the data of the output table but I cannot inspect those data until they contain columns of RDKit molecule type. When I filter out these columns, I can inspect data again as expected.

When KNIME crashes the last thing it writes in the log (in debug option) is the following:

2020-04-20 16:08:49,385 : DEBUG : main :  : OpenPortViewAction :  :  : Open Port View RDKit From Molecule (#1)

I’m using KNIME 4.1.1 with RDKit KNIME Integration 4.0.1 v.202002121352

Can anybody please help with this problem?

Here is an example workflow:
RDKit_mol_type_visualization_crash.knwf (17.9 KB)

Hi - what OS and version of it? (Also, the file size of that example workflow is a little small - if you didn’t export it including data, it would be more helpful to people debugging if you included the data (many people do not have structure files laying around.))

Hi,
Thanks for answering.
Data is included in the example workflow. It’s so small because it’s just a couple of nodes with just 1 molecule (minimal example).
Here I experienced the problem with Ubuntu 14.04.6 LTS, but in the past I experienced it also with newer Ubuntu versions (i.e. 16.04 LTS & 18.04 LTS) so now I decided to ask about it in the forum.
Can I help with something more?

Thanks for the follow-up information; perhaps you could launch KNIME from a shell and have it crash - it may dump additional logging or crash information to the shell. Also, do a find on your filesystem for files name “hs_pid*” and see if any have a timestamp appropriate to the crash.

In the mean time, perhaps @greglandrum could provide more insight?

Hi,
I can’t reproduce this on my windows machine; I will take a look on linux tomorrow morning, but I don’t think there’s a general problem with the nodes. Could you please try the workflow I’ve attached here to see if you have the same problem when you run the “Renderer to Image” node. That should exercise much of the same code that is used when you try to view the columns in the table viewer.

-greg
RDKit_mol_type_visualization_crash.gl.knwf (20.1 KB)

1 Like

Hi guys,
Thanks to both of you to take this problem into consideration.
First of all I ran KNIME from the terminal as suggested by quaeler to get more information about the crash. When I do this, I have the following additional information that may be helpful. It seems that is a memory(?) pointer problem:

*** Error in `/usr/local/knime/knime-full_current_version//plugins/org.knime.binary.jre.linux.x86_64_1.8.0.202-b08/jre/bin/java': free(): invalid pointer: 0x00007f3d6d243820 ***

Unfortunately it seems that the crash does not generate any “hs_pid*” file.

Effectively when I run the “Render to Image” node in the example workflow provided by Greg, I have the same crash, with the same “invalid pointer” error triggered on my terminal.

Can I help with other tests/info?

Gio

I can’t reproduce this on my linux box (running a more recent version of ubuntu, but that shouldn’t make a difference. The automated testing runs on an older version) with either the version of the RDKit nodes you are using or the most recent version.

I can think of a couple of things to try:

  1. Try installing the most recent version of the RDKit nodes: uninstalling the RDKit nodes, restarting KNIME, installing the RDKit nodes from the “Community Extensions (Experimental) update site” (the RDKit nodes there aren’t really experimental), and then restarting KNIME again and confirm that you have this version:
    RDKit KNIME integration 4.0.1.v202003091352
  2. If you really want don’t want to use the most recent version of the nodes, you can try just reinstalling the version you have: try uninstalling the RDKit nodes, restarting KNIME, installing the nodes again, and then restarting KNIME again.

-greg

Dear @greglandrum,

Thanks indeed for your help. I tried your option 2, but that doesn’t solve the problem.

Regarding your option 1: I enabled the “ KNIME Community Extensions (Experimental) ” repository, pointing at http://update.knime.com/community-contributions/4.1 but I cannot see the version you mentioned (i.e. “ RDKit KNIME integration 4.0.1.v202003091352 ”). I only see “ RDKit KNIME integration 4.0.1.v202002121352 ” which is the version I’m currently using and that, if I’m not wrong, should be on “ KNIME Community Extensions (Trusted) ” pointing at http://update.knime.com/community-contributions/trusted/4.1.

Do I miss or misunderstood something?

Gio

Hi @gcincilla,
The Nightly builds (a.k.a. “Experimental”) community extensions are on a different update site: https://update.knime.com/community-contributions/trunk

-greg

@greglandrum, I should have imagined but I confused it with “KNIME Community Extensions (Experimental)”.
Now I correctly installed RDKit KNIME integration 4.0.1.v202003091352 from the Nightly builds but I’m experiencing the same error:

It happens using both my workflow or the one you attached.

Additionally I made a test with the same workflow but using Ubuntu 16.04 LTS (instead of Ubuntu 14.04 LTS). I can confirm that I have the same error in the more recent version. Nevertheless this time I could get more information because when it crashes from the terminal, it leaves the following backtrace:

knime-rdkit_invalid_pointer_backtrace.txt (20.2 KB)

Maybe this can help to make you understand what is happening. Please let me know if I can be of help.

Cheers,

Gio

I noticed in the memory map that you have some Wayland libraries resident; on a lark, and given that there are some inconsistencies / oddities in Linux varying from desktop environment to desktop environment - could you try a different environment (e.g disable Wayland if its enabled; switch from Cinnamon to MATE; switch from Xfce to Cinnamon; …) to see if the crash no longer occurs?

@greglandrum - what desktop environment are you running?

The default Gnome environment for Ubuntu 19.04

I have have this happened before as well with older KNIME and RDKit versions on windows. It was always related to some weird structures which leads to crash when rdkit tries to generate an image.

So depending on how many structures you have, you could try to pinpoint the faulty one manually to send it to Greg.

Another option to simply make the workflow work is to use marvins free molconverter node and simply do a conversion (even to same format). That often cleans up such faulty structures preventing the crash.

1 Like

That’s a good general tip, but in this particular case the structures are all pretty simple.

My bad. I should have looked at the example workflow. I can only confirm that for me the example workflow also works just fine on win10.

Hi guys, thanks for keep on trying to solve my problem.
@beginner, thanks for confirming the situation on win10 but I think the problem appears with Linux OS.
@quaeler, I also have the default environment for Ubuntu 14.04 LTS, Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. In the first of these I tried to determine whether I was using Wayland with the following command, but it seems that I’m not, so I would say that the problem is not related with that.

loginctl show-session <SESSION_ID> -p Type

Please, do you have other tips or suggestions on how I can solve this problem?

Perhaps someone with access to the RDKit source code can use your symbolicated stack trace to determine what the specific invocation is that is crashing for you. In the meantime, perhaps you could try 19.04 since Greg is reporting encountering no problems on that?