Hi KNIME community,

I have a workflow that generates a Date that is equal to the execution date. However, the format of this date is local date. When I combine this date with other data and write to a table in Oracle SQL server I get a error stating the data type in Oracle is Date and the data type in KNIME is local date.

The same thing happened when I tried to capture the time stamp. KNIME generated the data in local date and time format and Oracle table was configured to use timestamp. I then changed it to Date and tried to get only Date to write to the table but that too failed.

Any idea how I can resolve this issue ?

Preferably I would like to write timestamp from KNIME to Oracle SQL
but I can settle with date only.
Oracle table can be changed to Date or timestamp format. I do not want to use varchar if I can avoid it.

Hey @Adiwakar,

Would you be able to share any of the errors you saw? It sounds like we just need to get the data in the right format, both in the DB and from KNIME.

I would recommend establishing the type in DB, then taking a look at the following thread: Convert Date to be read by Oracle

and there is also the underlying workflow on the hub.

Wali Khan


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.