Knime launch Error

1626428673354.log (518.8 KB)

There is bundle error while executing knime after update to 4.4
How should i recover the existing setup?
Please guide

Hello @shwetaoza,

have seen post you created in another topic and a bit confused (closed that one as topic is pretty old and deals with 2.x KNIME versions). Can you explain how did you perform update to 4.4.0?


When I tried Files->Update Knime it said it is updated
But the version used was still old 4.3.2
And on Internet it showed latest version as 4.4.0

Then I selected Preferences->Install/Update->Available Software Sites → Manually changed the Location version ending with old version was replaced by new 4.4 and kept all Enabled → Apply and Close

Then I tried Update Knime still it showed its up to date but it was not

Then tried Install Knime Extensions… → clicked Already installed? option → KNIME Analytics Platform → Update… → Finish → it ended well

While restarting it shows 4.4.0 version but it does not restart and gives and error with logs located in configuration folder.

It is not possible to update from 4.3.x to 4.4 via an update site. The reasons are that 4.4 builds on a newer eclipse and java version. You will have to download Knime from the website and install it from scratch.



Thankyou for reply.
So no one can directly update to 4.4 we would have to newly download it.
If same eclipse or java version was used then direct update was possible right?

Hello @shwetaoza,

when there are big changes (like Eclipse or Java update and possibly some other) then there is no direct update path but new install is needed.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.