KNIME Python Could not Start Python Kernel

Hi, I’m just learning how to integrate python to KNIME and while I already follow the instruction on Installation Guide. I found error while trying to run the script even though it’s already installed. It’s quite weird since I can execute it before I restart my computer.

This is the snap I took during the error happen. Is there any way I did wrong?

Unfortunately sometimes it is not so easy to bring KNIME and python together. There are some lengthy discussions in the forum (cf. below).

What sometimes worked for me was not using the .bat script but pointing directly to the python.exe (although it is not recommended by the ‘official’ guide)

As of now I have not brought together all the hints into one article.

Please note: some important packages like scikit-learn are not included in the yml file but you could install them via Anaconda.

So it is some trial and error. Also I am not 100% happy with Anaconda. Sometimes installations get corrupted or Anaconda messes the versions of packages up and would not be able to automatically repair it. So I had to reinstall the whole thing.

Another point. Sometimes it seems components of R or Python do not like long and complex paths. This should not be the case but it is in the real world.


The log hints to a problem with communication between KNIME and Python if it executes. On some corporate servers I have seen restrictions for KNIME to communicate with the outside world. There were sometimes settings that could help. I will have to look them up.

Oh one more thing. Sometimes there are problems with KNIME and one drive because Admins like to limit the type of characters allowed in file names and folders and KMIME workspace needs some of those special characters. It could corrupt whole workflows.

1 Like

I see that now, I’m using one drive to store the .bat file. It didn’t work then but it works now after I restart my computer.

Thanks for the response, I think I will need to store the data in my laptop just to be safe.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.