KNIME Python Integration

Hi Community,

I tried to use the new KNIME Python Integration in the KNIME Analytics Platform 4.7. I followed the instructions (KNIME Python Integration Guide). Here are my steps:

  • Installed Miniconda3 (Version py39_4.12.0)
  • Set the path in Preferences/KNIME/Conda (Conda version: 4.12.0 gets detected)
  • In Preferences/KNIME/Python I set the Python environment configuration to Conda and successfuly created a new environment (py3_knime) by pressing New environment... (Python version: 3.9.15 gets detected)

However when I try to open the Python Script or Python View node it keeps showing Starting Python... in the bottom left corner forever. When I try to execute the node it also keeps executing forever (I left the default script untouched for testing, so only the input table should be copied to the output).

In the Console I found the following output:

ERROR Python Script 3:13 Failed to initialize LZ4 libraries. The Columnar Table Backend won’t work properly.
ERROR Python Script 3:13 Error loading model settings
ERROR Python View 3:15 Error loading model settings

Did somebody get the same results?

Best regards
Martin

Hi Martin,
This is strange. There should be more information in the KNIME log (View → Open KNIME log). Can you post the log here?

The Python node uses the columnar backend to transfer data between KNIME and Python. The columnar backend itself uses a native library for lz4 compression. Apparently, loading the library failed. Hopefully, the log will give us more information on why this failed.

Best,
Benjamin

We had this problem before when the “Columnar Table Backend” was not installed correctly. Therefore, we added a dependency from the “KNIME Python Integration” to the “KNIME Columnar Table Backend”. Could you search for the “KNIME Python Integration” in the installation details (Help → About KNIME Analytics Platform → Installation Details) and check that the “KNIME Columnar Table Backend” is one of its dependencies? Also, the exact version of the “KNIME Python Integration” might help us to get to the root of this problem.

1 Like

Thanks for the helpful hint! I could find the issue: C:\Users\<<user>>\.javacpp\cache\windows-x86_64\jnijavacpp.dll is getting blocked by a company policy. Is there a chance to install the dll under anoter path?

Best regards
Martin