KNIMe rearranges column on its own

Hello everyone,

i encountered a strange behaviour in KNIME.

I have two identical excel files with identical sheets, the only difference is the year. In sum the there are 14 sheets from which i need only 12 (month in a year).
I used the normal basic workflow for extracting and joining the sheets. With the excel file for 2021 everything works fine as expected.
But when i go th 2020 (and i cant stress this enough out) which has a identical layout, KNIME moves a column on its own, which then leads to an error…
I dont understand why KNIME does this…

My workflow:

The original order from the excel sheet and how i wawnt to keep it (which works perfectly fine for the first file)

But KNIME is putting one column to the very end (and changes it to “integer”) during the process…

which then leads to the error message:

“Input table’s structure differs from reference (first iteration) table”

I already tried to make a new sheet in the excel file with the same data, i did various formatting in the sheet, tried different setting in KNIME, but nothing helps…

Can someone tell me why KNIME is moving the column?

Kind regards

@Stbin you might have to check the advanced tab of the excel reader


Hi @Stbin,

This is interesting. The type change might come from the data in those columns. The Reader tries to guess the type based on the first rows. Recently there has been a change with the default value, it has been increased to 10.000, which should fix that issue. You can check that for yourself in “advanced settings” → “table specification” → “limit data rows scanned”.

The SAP-Kundennummer has a different name in the second screenshot. Does that come from the files or was that done by KNIME?

Can you share your workflow, maybe even a few rows of those excel files? It doesn’t have to be real data, it’s fine if you anonymise it. This problem will be hard to track down otherwise.


shame on me, you are right, these are two different names. I was so frustrated yesterday that i didnt see this error in the excel file. I am sorry.
Now everything works fine.

thanks for this hint, i will keep it in mind for the future :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.