KNIME requires “[GLIBCXX_3.4.20” but Cent OS 7 supports max “GLIBCXX_3.4.19”

Hi,

We tried to install KNIME on RTI machine. But the machine not supporting for this installation.

KNIME requires “GLIBCXX_3.4.20” but Cent OS 7 supports max “GLIBCXX_3.4.19”.

Any support is provided by KNIME in this case, please let us know at the earliest.

Thanks & Regards,
Gopal

Any updates on the above error please. I am trying to deploy it on CentOS Linux platform.

Thanks & Regards,
Gopal

Hi @gokarana_1977 -

Could you try the suggestion from Martyna in this thread?

1 Like

Hi ScottF,

Thank you so much for quick response.
I have one question which version of KNIME does not need this particular Versioned Library and also supports to build CNN node chain for image processing having input as Coloured images instead of grey scale.

Appreciate your quick response.

Thanks & Regards,
Gopal

If you are able to manually install the library linked in the other thread, you could try rolling back to KNIME AP 4.6. As best I can tell, this issue with CentOS 7 didn’t popup until the AP 4.7 release.

As for your other question, have you searched the KNIME Hub for example workflows about CNNs, like the one below? Both 4.6 and 4.7 should support those just fine.

Dear ScottF,

Good Day!! Thanks for your response.

Our IT Admin tried to install the specified library, but got the following error:

SESSION 2023-01-30 23:58:06.497 -----------------------------------------------
eclipse.buildId=unknown
java.version=17.0.5
java.vendor=Eclipse Adoptium
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2023-01-30 23:58:08.034
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: /home/thales/Downloads/knime_4.7.0/plugins/com.equo.chromium.cef.gtk.linux.x86_64_95.0.6/chromium-4638/libequochro.so: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20’ not found (required by /home/thales/Downloads/knime_4.7.0/plugins/com.equo.chromium.cef.gtk.linux.x86_64_95.0.6/chromium-4638/libequochro.so)
at java.base/jdk.internal.loader.NativeLibraries.load(Native Method)
at java.base/jdk.internal.loader.NativeLibraries$NativeLibraryImpl.open(Unknown Source)
at java.base/jdk.internal.loader.NativeLibraries.loadLibrary(Unknown Source)
at java.base/jdk.internal.loader.NativeLibraries.loadLibrary(Unknown Source)
at java.base/java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.base/java.lang.Runtime.load0(Unknown Source)
at java.base/java.lang.System.load(Unknown Source)
at com.equo.chromium.internal.Engine$1.loadLibrary(Engine.java:73)
at org.cef.SystemBootstrap.loadLibrary(SystemBootstrap.java:36)
at org.cef.CefApp.startup(CefApp.java:569)
at com.equo.chromium.internal.Engine.loadLib(Engine.java:80)
at com.equo.chromium.internal.Engine.(Engine.java:45)
at java.base/java.lang.Class.forName0(Native Method)
at java.base/java.lang.Class.forName(Unknown Source)
at com.equo.chromium.ChromiumBrowser.earlyInit(ChromiumBrowser.java:58)
at org.knime.js.cef.CEFEarlyStartup.run(CEFEarlyStartup.java:71)
at org.knime.core.util.IEarlyStartup.executeEarlyStartup(IEarlyStartup.java:104)
at org.knime.product.rcp.KNIMEApplication.start(KNIMEApplication.java:120)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:136)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:402)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:596)
at org.eclipse.equinox.launcher.Main.run(Main.java:1467)
at org.eclipse.equinox.launcher.Main.main(Main.java:1440)

Thanks & Regards,
Gopal

That log indicates the library is still not being found by KNIME. Perhaps it’s in the wrong place, or its permissions need to be updated?

Is KNIME 4.6 showing the same problem for you?