knime-scripting development "The corresponding plugin bundle could not be activated"


I’m trying to customize knimie-script, and get it up and running in my development environment. However, I can not see any scripting node available in node repository, for example, Community Nodes/Matlab Scripting.
I have gone through Create a New Java based KNIME Extension, and successfully see the number formatter node in the launched Knime. I am not sure why I can’t see the scripting nodes.

Eclipse version: 2022-06
Branch of knime-sdk-setup: releases/2022-12
Branch(tag) of knime-scripting: v4.3.0_knime4.7
Java version: 17.0.11

I made sure that the correct JRE is used

Some pictures for my environment

I have tried different branch of knime-scripting, also tried changing compiler compliance level, but no luck. I am new to the whole development process, could someone sheds some light on it?
Thanks in advance.

Hi @beginnerJ,

great that you are trying it out!

On a first glance quite some repositories (including the de.mpicbg.knime.knutils mentioned in the error message in the console) seem to have issues: there is a small red/white symbol next to the folders on the left. If you open the perspective Problems in Eclipse, there should be more insights if you click on these folders. Could you gather some more details there?

Best regards

1 Like

Hi @beginnerJ

Can you check which JRE is used by the debug configuration? It should look like this:

You edit the configurations when you click on the little downward arrow next to the debug symbol:


1 Like

Hi @steffen_KNIME
It’s fun to explore new things!

The modules seem to depend on each other, so I import all of them(knime-scripting)
Looks like there is a missing required knutils.jar

Hi @gab1one ,
Thanks for your reply!
Here is my config.

I also found this strange, because Knime 4.7.x use Java 17, however, it’s Java 11, when I open the KNIME Analytics Platform.launch. I changed the version to Java 17, but I got a blank Knime window without any information.
In the document:

Hi @beginnerJ,

The error with the missing knutils.jar file looks like a problem in the build configuration of that mpicbg.knutils plugin. Note that this extension is developed by the KNIME community at the MPICBG, not KNIME. Their expert for this extension is @niederle.

To ensure you have a correctly working basic setup, please close all projects besides the sdk setup one and try to launch the AP in debug mode. To ensure you are launching into a clean state select the “Clear” option in the debug configuration.


1 Like


I am the developer of the (community) knime-scripting nodes. As it’s only a minor side project my knowledge about the whole building process is pretty limited.
Anyhow, I wanted to ask whether you did run the maven build for the scripting extensions and if this was successful. This should create the jar-files you are missing…

Thank you all for answering.
I tried and solved the issue by removing knutils.jar in ‘config build path’. I’m not sure why knutils put its jar in classpath.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.