Knime Server_4.11/Executor_4.2.4 Execute Executor in Gui Mode


in our Environment Knime Server and Knime Executor are installed in Red Hat Linux als Systemd Services. No problems so far.
I testest a small Java-Gui App running on the Server with putty using X11 forwarding and Xming as the app on the pc to display the gui , which worked.
Now I tried to run Knime Executor in
-bash-4.2$ ./knime
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
An error has occurred. See the log file
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
no swt-pi4-gtk-4932r18 in java.library.path
no swt-pi4-gtk in java.library.path
Can’t load library: /knime_storage/home/knime/.swt/lib/linux/x86_64/
Can’t load library: /knime_storage/home/knime/.swt/lib/linux/x86_64/

Which command is used to start the Executor in Gui Mode.
All components were installed using the command line option.

thanks in advance

Hi @b_kochs ,

Would you mind letting us know the reason for starting the Executor in GUI mode? Usually this just runs in the background and you update the executor or install new extensions by using the command line. To run the executor on the server you can run the, or install the executor as a SystemD Service following these instructions:


Intended purpose is to install knime-extensions and updates.
The problem has been solved in rhel by installing:
yum install gtk3-3.22.30-5.el7.x86_64
yum install xorg-x11-apps → which lets you execute xclock
I doubt that xorg-x11-apps are really needed for executing java gui programs.

Greetings B.Kochs