Knime server authenticating issue

#1

Hi,

I got an error to connect to KNIME server: “User ‘knimeadmin’ cannot be authenticated, probably the password is wrong”, meanwhile the server is not running at backend, logging in through webportal also has same password issue. I’m sure I was typing into the correct password. Is there any other possibility to cause this error? Thanks.

Xiaoan

0 Likes

#2

I tried re-install knime server (after deleting old folder) and solved the issue. But still want to know why the password issue happened…

0 Likes

#3

Glad that the reinstall fixed the issue, but shouldn’t be necessary. Could ideas to think about in no particular order.

  • During the install the installer will prompt to create an auto-install.xml file at the very end. I suggest doing. It will help automate the install if a reinstall is needed. It will also contain the password you set an install time. We advocate changing the password later to a more complex password, but I have used this in the past when the default password doesn’t get changed. It usually defaults to the hostname, but sometimes the FQDN gets used.
  • If you do lose the password there are ways to connect to the database and reset it via command line calls. Easier on LINUX but do-able on windows.
  • I’ve also seen people take a copy of the default H2 database and keep that around in case of an issue, although very rare.
  • Another option is to immediately create a second user and assign them the admin role, this allows for one admin to change the password of the other.
  • One more, but certainly not the last, if you have created other users on the system, you can set them temporarily to an admin via one of the config files to allow for the previous step to work, and the set them back to a consumer or user.

Feel free to post or reach out if this comes up again or any other issues/questions

2 Likes

#4

Thanks for the feedback. Will keep watching

0 Likes