KNIME server connector


I am looking at the KNIME Server Connector node. When I work locally it works great to execute a workflow on KNIME server, even if I am editing copy of the workflow on the server. But when I right click on the workflow in the server and execute the workflow the connection time out. The url is https and the test server we run is a single server setup. I think it may be the url that is an issue when executing the workflow on the server and it has to reverence itself. The running workflow is suppose to call the Test_01 workflow.

Hi Willem,

could you share the error you encounter with us?
It may be “PKIX path building failed”, “no valid certificate found” or similar, which would back your presumption regarding https. You could also test by changing the URL to http.

Using https isn’t necessary if server and executor are on the same machine, though it is possible.

To import the server’s certificate in the executor, see here: Resolving Common KNIME Certificates Problems - YouTube

However, the setup may involve an extra step, as the server certificate is likely valid for a domain (e.g., but the executor may be connecting to the server via “localhost” or
You can set the parameter com.knime.server.canonical-address to the correct address in the WebPortal under Administration > Configuration and restart the executor.

Connecting via domain name and encrypting local traffic is ever so slightly less efficient and doesn’t increase security, but it will allow the executor to connect to the server via https.

Hope this helps!

Kind regards

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.