KNIME server increasing timeout

timeout

#1

I have attached part of the workflow where I read the tables using database reader, make some transformations and write the table back to the databse using pythong script (web hdfs). The database reader runs in my local (I have set the timeout value to be much higher). When I put in the KNIME server, it fails as it is only set to 15 seconds.

Is there a way to increase this value in the KNIME server?

Alternatively, is there a better way of doing it?


#2

Hi there,
You’ll need to setup the server preferences to also increase the DB timeout. With recent server versions there is a file called /config/preferences.epf.template.

That contains the line:
/instance/org.knime.workbench.core/database_timeout=7200
The timeout is in seconds.

You can copy the preferences.epf.template file to preferences.epf and edit the preferences.epf file to set the preferences that you need (don’t remove the line file_export_version=3.0, or !/=)

Once you’ve made those changes restart the KNIME Server for the preferences to take effect.

Best,

Jon


#3

Hi @jonfuller

Thanks. Is this option available for Knime server version 4.4 ?


#4

Yes. Create the preferences.epf file manually. It needs to contain the three lines ( and have the same file permissions as the rest of the repository).
file_export_version=3.0
!/=
/instance/org.knime.workbench.core/database_timeout=7200