Knime server not working after upgrade to 4.11

We have a Knime server running on AWS.

We just upgraded from 4.10 to 4.11, keeping TomEE v7.0.5. ( We decided not to migrate to Tomcat yet )

However something went wrong with the update and our server doesn’t work anymore.

I’m attaching two log files ( localhost & catalina )
At 19:52 I started the server ( you can already see some error messages )
At 19:58 I tried to access the webportal ( server_url/knime ) But I got a “500” error.

Please note that “server_url” ( withtout the /knime suffix ) works and shows the tomcat home page.

catalina.2020-08-31.log (106.3 KB) localhost.2020-08-31.log (30.8 KB)

Can someone please help me with this critical problem?


This is solved.

The problem was that I didn’t download the knime-tomcar.jar ; because I thought it was only relevant to the Tomcat version of the Server, whereas I am using the TomEE version.


Hey Sébastien,

Thanks for the update :+1: Good to hear that it is solved now.

All the best,

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.