KNIME Server - User cannot be authenticated

Hello,

I’ve updated the server to 4.15. Everything’s great except the user management. If a user is not in the admin group, it can’t connect. Tried through the webportal and with the workbench.
As soon as I add the user to the admin group, it works.

I’ve checked the configuration in the webportal and I’ve authorized the group “knime” in every possible connection type (user, consumer, …).

The message is the following:

Hope you can help me ?

Best Regards
Jerome

Hello Jerome,

What authentication method were you guys using before upgrading to KS 4.15? Was there some kind of LDAP/OAuth/etc method being used for authentication?

When you upgraded. did you just replace the knime.war/knime-tomcat.jar files for the server side of the upgrade, or did you do a full new-install from the installer .jar? (This would give you a stock apache/conf/server.xml, which would be missing the Realm definitions or other customizations for the authentication.)

If it was a full install and you use H2 database authentication, did you copy over the old user db into the new installation?

As you are obviously a server customer, I recommend writing in to support@knime.com and getting direct support; we can review config files and other details that way, or even schedule a call to go over it directly and get you back up and running.

Thank you,
Nickolaus

1 Like

Hello Nickolaus,

Nothing special. The basic authentication method of KNIME, with the user management within KNIME directly.
I tried to do the upgrade, using the How To from KNIME. As it was not working correctly with the users. I did a full new installation. The problem is the same.
With the new installation, I’ve created new users.

Now, when I’m adding a new user with the group “admin”, the user can connect. As soon as I remove th group admin it doesn’t work anymore. Then, trying to add back the group “admin”, but the user is not anymore allowed to connect.

Yes I’ll do that. Thanks for the support.

Best
Jerome