Knime server workflow not running

#1

Hi,

I am using KNIME version 4.0.1 (Desktop and server) at work. Using Python version 3 in local. I created a knime workflow and it runs smoothly in my local space. However, in the server, I am having problems running it.

Couple of errors I noticed in different workflows:
For one, the workflow starts with DB connectors, table selector and reader. I using the HIVE JDBC connection.

Another workflow uses a python script (web hdfs package) to write the table to hive and i get an error when deploying in server. (Use successfully in the past before).
Screenshot of the error.


The python script nodes generally work fine local and is able to start kernel.

Please note I was able to run similar workflows in the previous server version/ able to run it successfully in the local space.
Appreciate you help. (Also emailed support on the first issue but no response yet)

0 Likes

#2

Hi @shalinirs,

First: I have tried to find your already opened ticket on our Support System, as I didn’t succeeded, can you please send me the ticket number per private message? I will merge the open tickets. Thanks in advance.

How was your server upgraded, following the steps of the upgrade guide, merging the ini files included?

I am asking because the error message shows that the knime executor can’t access the python installation on the server. There might be a wrong path configured.

Best,
Michael

0 Likes

#3

Hi Michael,

We resolved the Python error. Looks like the KNIME server version had Python version 2.7. Python script node had an option to choose Python 2/ 3. Choosing Python 2 worked.

I will update soon on the first issue.

Thanks,
Shalini

1 Like