KNIME Slave not compatible with KNIME Server - trying to execute flow on server


I am running Server 2008, with an existing installation of KNIME 3.1. The server is behind a firewall.

I purchased a Server Lite license and installed it (2.1.2). I am able to save and open flows on the server. I can execute the flows in KNIME . However, when I try to execute them on the server an error is returned - "KNIME Slave 4.2.0 is not compatible with KNIME Server 4.1.2".

I thought it might be to do with the version of KNIME so I installed 2.12.2 (from the product download page) and changed the knime-server.config to point to the 2.12.2 version, but the error persists.

I also Installed the updates for 2.12 from the products download page.

I have not been able to find any references to 'KNIME slave' and am out of ideas how to proceed.


Paul S

You installed the server-side extensions from the update site of server 4.2. You must install them extension from server 4.1 update site. The server-side extensions must always match the server's version.


I'm facing the same problem, I installed the Server 4.4.0 from this site.

I have the KNIME Server RMI Slave 4.4.0.v201612012034 installed and KNIME ServerSpace 4.4.0.v201612012034 installed but still when I run the workflow it gives me the follwoing error:

"KNIME Slave 4.4.1 is not compatible with KNIME Server 4.4.0"

Not sure what I;m doing wrong here.Glad if anyoen can help.



Mohammed Ayub

No worries. updating KNIME Server to version 4.4.1 solved the problem.

Thanks !

Mohammed Ayub