First I got this error message “it was created with a future version of KNIME (4.1.3.v202005121100). You are running 4.1.2.v202003050920.”
So I updated my Knime Server using the Disk swap method and then I updated executors using the update-rmi.sh script but I got this error message “KNIME Slave 4.9.2 is not compatible with KNIME Server 4.10.3.0063-565e8baa7, at least version 4.10.1 is required.”
My problem here is I’m actually using the last version of Knime server 4.10.3 on aws Marketplace but I got a message error telling me that at least version 4.10.1 is required
Killing all leftover executor processes and to restart the whole the EC2 instance didn’t work for me.
What update repositories did you use when running the update-rmi.sh script?
Also, in the executor/plugins/ folder, do you see com.knime.enterprise.slave.x.x.x? Can you tell us what the full file is listed as?
Thank you for your response
So to answer you question, I used https://update.knime.com/analytics-platform/4.0 when I run the update-rmi.sh script ./update-rmi.sh http://update.knime.com/analytics-platform/4.0
I checked the executor/plugins/ folder and the the file is listed as below: com.knime.enterprise.slave_4.10.3.v202004030927.jar
Please use 4.1 for the update repository and also use the trusted repo as well, and then try to re-run the update-rmi script:
If this does not fix the issue, please wipe the executor, and install the newest version.
Just checking in to see if any of the suggestions worked?
Hi. I experience the same issue. I update knime server and knime executor to the newest releases. In knime_executor/plugins I had both: com.knime.enterprise.slave_4.9.2.v201909242005.jar and com.knime.enterprise.slave_4.10.4.v202005112253.jar. I deleted the old ones but it didn’t help.
Can you please try uninstalling/deleting the executor, and re-installing?