Knime SMB Connector failing after upgrading to 4.6


We recently updated to Knime 4.6 (change log) and after doing so one of our workflows that uses an SMB Connector node started failing. The SMB Connector node completes successfully but the CSV Writer node that used the SMB Connection fails with the following error.

ERROR CSV Writer 8:92 Execute failed: com.hierynomus.protocol.transport.TransportException: java.util.concurrent.ExecutionException: com.hierynomus.smbj.common.SMBRuntimeException: com.hierynomus.protocol.transport.TransportException: EOF while reading packet

Has anyone else experienced this?

Hi @dataMover ,

Thank you for bringing this to our attention. I have recently received another ticket with the same error message relating to the SMB node and 4.6.0. I will raise another JIRA ticket to our development team to take a look into this.

As a note, .0 releases are meant to be versions for people to explore our new features and is not meant for production environments, so usually there are a few bugs that haven’t been fully patched just yet. With our .1 release of 4.6 most of these issues should be resolved. We appreciate your patience while we work on sorting out the 4.6.0 release issues.



Hi @dataMover

this looks like a bug in the smbj library which we are using for the SMB Connector node (with AP 4.6 we updated the library version due to other bugs). We are unable to reproduce the issue on our end here and it seems to only happen with some SMB fileservers. Would it be possible to get precise info about the configuration of your SMB fileserver and/or some server-side logs? From the looks of it, the fileserver is closing the connection, but we have no idea why.


Have you fix the problem? Today after I upgraded to 4.6.1, I met the same problem with SMB Connector node. I can’t even browse the directory.

After I downgraded the extension, it worked again.


Hi, I am facing exactly the same issue.
Any update about the topic?

I downgraded that particular set of nodes from KNIME Basic File System Connectors to 4.5.2 and got everything working. However, 4.5.2 has a dependency issue with KNIME Personal Productivity Tools, so I removed that extension and all is well :slight_smile: Hopefully they can figure out the fix :slight_smile:


To this point at KNIME we are still unable to reproduce the issue as it seems to only happen with some file servers, e.g. certain NetApp appliances.

We did an upgrade of the smbj library update with 4.6.0 which seems to cause this. The new smbj defaults to using SMB3, whereas the previous version preferred SMB2. Our current hypothesis that this is causing the issue. We are currently adding a way to force SMB2 to the SMB Connector node, which will be released with AP 4.6.2.


I had the same issue with SMB connector node after upgrading to KNIME 4.6.1 - but I can confirm that an upgrade to 4.6.2 solved the issue!
Unfortunately we will have to update our KNIME Server version as well :confused: .


Hello @erik_pinter , @chemgirl36 , @misterhd , @scnliuqin and @dataMover ,
we are revisiting this problem and need your help to identify the cause. Can you please tell us what type of SMB server you are using that causes the problem.
Thanks for your help

1 Like

Hello Tobias,
I’m not 100% sure but for your reference:
Our file share team confirmed that Bosch File Shares are running on a HW from vendor NetApp which is using SMB 3.1.1, but in KNIME I can only use 3.0 or older version,
with 3.0.2:

with 3.1.1 or 3.x:

And now we have another problem, for file shares which have enabled “Transport encryption”, SMB Connector node is not working anymore (in AP4.6.x or 4.7.1).

Thanks @scnliuqin for the information. We are in contact with the developer of the library and I have forwarded your information to him.

1 Like

I had this problem and it was fixed on 4.7.7 this happened to the share drives type Unity Storage
BUT now on v4.7.7 I’m getting similar error with the type Blair Netapp share

But now fails sometimes and sometimes not:
ERROR SMB Connector 1584:210: Execute failed: STATUS_OTHER (0xc0000001): Authentication failed for ‘ps330231’ using com.hierynomus.smbj.auth.NtlmSealer@1f8dd90a

I had to migrate the drive to Unity Storage as workaround.