KNIME Snowflake Integration Installation Error

Dear Knime Community,
something very strange is happening in my Knime.

Version: KNIME 4.7.0
Machine: MacBook Prov with Apple M1 Pro, MacOs 13.2 (22D49)

  1. I opened a Knime file (.knwf)
  2. It asked me to install the “KNIME Snowflake Integration”
  3. i have installed it
  4. restared Knime
  5. opened the file again
  6. It still asks me to install the “KNIME Snowflake Integration”
  7. I open the installer again
  8. It does not allow me to continue because it say that it is already installed (attaching screenshot)

How can I solve this? Am I doing something wrong or is it a bug?

Hello @nicolas_deel ,

Welcome to the Forum!

Strange things sometime happen :slight_smile:
Could you please try to uninstall the Snowflake extension then re-install it again?
Did it help?

Kind regards,

1 Like

I have already tried, and has not worked.

Are there any special un-installers to use? I have just trashed the application from my Mac Folder.

For the Analytics Platform application there is no un-installer, it is enough if you delete the application and then re-install it.
For the Snowflake Integration (and for all the others of course) you can use the built in function for the uninstallation:
(File->Install KNIME Extensions…-> ‘already installed’ → select the software to uninstall → Uninstall)

Which workflow would you like to run?
Is it possible to share it?
Can you run other workflows using Snowflake or you experience this behaviour with all of them?

I don’t have the button to uninstall in that Window on the Mac version. Screenshot:

@nicolas_deel , @dora_gcs my impression is that KNIME does have a systematic problem when it comes to (especially Big Data related) extensions with the new Apple Silicon version. I very much hope this will be sorted out with the next release (AP-19894).

Oh, ok. Do you know when it will be released?

@nicolas_deel I have no idea when this will be available. Can you try and install the Intel version for Mac (which will run via Rosetta) to see if this might be related?


We released a fix with KNIME 4.7.2 that should fix the Big Data installation on Arm64 Mac.

@nicolas_deel does this problem persist with KNIME 4.7.2?



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.