KNIME startup fails

KNIME has always worked reliably, but suddenly I have this issue:

When I start KNIME, everything seems normal, and I get  the view of the last project I worked in. Then the screen disappears without a message after about 0.5 second.

System : KNIME 2.9.0 64 on Xubuntu 14.04, OpenJDK-7.

Since there is no error message - any ideas how to solve/diagnose this?

Well, I had something similar a while back. It was a fault that developed in the last workflow. You could go to the knime workspace file directory and temporarily rename that workflow folder. Then relaunch knime, hopefully all you will get now is an error about a missing workflow. 


I could also be problem with the browser. You are not using the latest KNIME version therefore it may crash under Linux when it shows HTML content. You can update to the latest version with the following command:

./knime -nosplash -consolelog -application org.eclipse.equinox.p2.director -r -d <knime-directory> -u org.knime.product.desktop -i org.knime.product.desktop