Knime, ubuntu and mysql - could not decrypt password


I've just installed Knime v1.3.3, (on linux, ubuntu gutsy 7.10)

I'm having trouble connecting to a mysql database (I haven't tried any other databases - so i'm not sure if the issue is specific to mysql)

In the database reader, my parameters are
database driver: sun.jdbc.odbc.JdbcOdbcDriver

database url: jdbc:odbc://localhost:3306/testdb

the user has full access to the database, and no password (works fine through a perl connection)

Knime asks for an encryption key - and then throws this warning:

WARN Database Reader Configure failed: Could not decrypt password.

I read in another post that there were some encryption issues with gnu java, but i noticed that this version of knime installs its own java locally (and, as far as i can understand the config details window in knime, it appears to be using the java it came with).

I tried installing the sun java just in case this fixed things, but to no avail.

any suggestions?



Hi bill,

I am not sure, if you can use sun's default driver to connect to a mysql database!?! However, you should first load the mysql database driver using the "Load" button, where you can select a Jar or Zip file which contains the corresponding database driver. All drivers are then available in the combobox for selection, please select the com.mysql.jdbc.Driver and enter the database url as jdbc.mysql://localhost:3306/testdb. In some cases, it might also work if you just enter obdc:jdbc:testdb, for example when you run a local MS Access database under Windows. (I know you have Linux.) Anyway, it should work fine now.

The warning message is strange. Did you get this message while closing the dialog before you entered the encryption key. Btw, the encryption has to have at least 8 characters - even if the password is empty. I am currently working on a new solution for this nasty issue.

Please let me know if things run better now...


Thanks Thomas

yes, it is working now - i think the problem was that i wasn't using the mysql specific driver (sorry - not a java person!)

as to the warning message, it appeared after i entered the encryption key and closed the dialog box.

thanks for your help