Knime update failure

I’m trying to run an update for Knime and various component extensiosn, mostly to versions 5.2.3, but the process fails due to denied access to some of the subfolders/libraries. I’ve checked the access permissions for this particular folder and these files, and there is no difference from other folders. The reported errors are:

An error occurred while installing the items
session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=[R] --> [R], action=org.knime.product.p2.actions.ShellExec).
ShellExec command exited non-zero exit value:
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\crc32c.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\ffi-8.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\flang.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\flangrti.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\libbz2.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\liblz4.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\liblzma.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\libomp.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\libssh2.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\snappy.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\utf8proc.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\Library\bin\zstd.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\msvcp140.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\vcruntime140.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\vcruntime140_1.dll - Access is denied.
C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\zlib.dll - Access is denied.

Any recommendations to get rid of this issue ?

Thank you for your help


Hi @sparel,

Did you install KNIME as administrator but are running KNIME now from your normal user account, and not as “administrator”? If so, could you try to run KNIME as administrator and then update the extensions?



Hi @carstenhaubold ,
I don’t think I installed Knime with elevated priviledges, although my account has local admin rights.
I tried to update Knime again, and I get the same issue. If I remove the Knime AI extensions, then the update goes through without any issue. It seems that it only fails for these Python LLM libraries.

Furthermore, upon restarting Knime, I noticed the following error message in the console:

ERROR PurePythonNodeSetFactory            Failed to parse Python node extension at path 'C:\Program Files\KNIME5\plugins\org.knime.python.llm_5.2.0.202312061509\src\main\python'.
Cannot run program "C:\Program Files\KNIME5\bundling\envs\org_knime_python_llm\python.exe": CreateProcess error=2, The system cannot find the file specified

Dear @sparel,

could you try uninstalling and then re-installing that exact extension?

Best regards


Hello @steffen_KNIME ,

Thank you for your feedback. It seems that this has solved the issue. I de-installed the AI extensions and installed them back, and now I don’t get the error message in the console anymore. Let’s see if things run smoothly upon the next update.

Thanks again and best regards


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.