KNIME with Remote R intigration

Hi Team,

I am trying to connect R which is installed on a remote machine on windows plarform, from KNIME server installed on a windows 2008 R2.

I am able to setup the library path by chaning in the KNIME preference setting. But I am unable to run any of the R node and getting the following error.

Please help me to resolve the error.

Hi Balaram,

Unfortunately the screenshots that you sent don't give enough information to debug. Can you find or confirm the following:

1) Which version of KNIME Analytics Platform are you running.

2) KNIME Analytics Platform and R is installed on Windows Server 2008 R2, that you are connecting to via remote desktop.

3) If you open the KNIME.log (View > Open KNIME.log) and then run the R node to reproduce the error, what additional information is added to the KNIME.log file.



I had the same error recently with R and Windows 10. In my case, it was caused by R being installed into a subfolder of C:\Program Files\ (with some default restrictions imposed by Windows).

When installing the Rserve package, R was warning that the default library location wasn't writable, and installed the package to a subfolder of the user home directory.

For some reason, KNIME then doesn't complain when you configure it to this R installation, but every R node fails with "R could not be initialized". (I think KNIME preferences should be improved to perform a better check and complain early in this case.)


We could solve it on our side by installing R to a user-writable folder (e.g. C:\Utilities\R-3.3.3) to make sure that install.packages() puts all files below the same installation folder that's been configured in KNIME.

Hope that helps,


Thanks for the information Jan. I've filed a bug report to cover that issue.

@Balaram can you confirm whether that solves your issue?