knime Workflow editor


I was willing to use a mac book air as a worklow design platform, and therefore I proceed to install Knime 3.3. Everything went fine untill I open the newly installed app.

Much to my surprise, only half of the screen is available for the workflow editor, a very large grey vertical band is present, preventing the use of the full extent of the WF editor space. This band is more like a very large window border that i cant resize. I did poke colleagues brains, browse the forum and internet, tried some of the advices given, not much success. 

i joined a screen shot here for you to have a look.

any advice is welcome. Thanks in advance for your time and support.

What often helps when the screen layout is messed up: Maximize and revert one panel, either by double clicking the tag bar or hitting ctrl+M (on the Mac).

-- P.

hi, it maximizes as you described, but does not go beond the grey bar (screen shot).Playing back and forth with the maximize/minimize does not remove the wide grey zone.

thanx for your time and suggestion.


well, really no good Samaritan for me on this one?


I use a Macbook (macOS Sierra) but I never experienced this. Have you tried View>Reset Perspective?

Hello, yes, i did try the reset perspective, without effect.

thank you.


hi, after a week teaking the machine with no install OS resolved the issue.

thx for support and time.



At risk of resurrecting a zombie thread, creating a new workspace worked for me.  Made sure not to copy any settings over.  

1 Like

It is working!!!
The last solution based on creating a new workspace works!!!

I am working with a Mac Book High Sierra 2016

Thank you so much!

hey there,
I’m facing the same problem. but creating a new workspace does not help. either does maximize/minimize or resetting the perspective.

does anyone have further suggestions? I’m running windows 7 and the newest knime version.

thank you in advance

Hey I am also facing the same issue. Have tried all the above (apart from reinstalling the application). Did you find a fix?