Knime workflows are failing while running in a zip file

Hi,

I am trying to run Knime workflow as given in the knime website. But am getting error saying that ERROR main BatchExecutor Workflow is locked by another KNIME instance

Please help me in solving this. Below mentioned is the command which I am trying to run

knime -consoleLog -noexit -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -reset -workflowDir=“C:\Knime\latest-knime\help”

I have a zip file in side help folder with the name workflow.zip and it contains to knime workflows.

i also tried giving zip file location by changing it to -workflowFile=“C:\Knime\latest-knime\workflow.zip”

Could you restart your machine once - and run your batch process again?
It could be that a previous batch run is still blocking the file

Tried no luck. Same error.

Could you check the knime log in the knime gui after the batch execution fails?
->maybe clear the log before execution and close knime while the batch execution runs

Maybe there is more Information what is going on :thinking:

If i run through GUI i dint see any problem as i am running one workflow at a time. But while running as a zip file, which have more than one workflow i see that error. Can we run multiple workflows in zip file from command line

I think you cannot execute multiple workflows at once using batch mode.
You have to time them so they do not run at the same time…
Maybe someone else knows more :frowning:

Hi Team,

Can you please help me fixing this issue.