Labels in Decision Trees are cut

Hi Guys,

I'm still quite new to KNIME. I'm using some Decision Trees for explorative tasks, but unfortunately when I view the Tree, the longer labels above the splitting points are cut and not fully displayed. I tried to use the "Decision Tree To Image"-Node to convert the Tree Output into an image that I can print on a big sheet of paper. However, not only the labes are cut, but also the Splitting Values are not shown anymore if the label is too long (see attached screenshot).

I couldn't find any setting to overcome this issue. Do I miss something?



Hi what I did was to add the node "Decision Tree to Image" after the "Decision Tree Learner" and then add the "Image Port Writer" to the "Decision Tree To Image".  

Tell me how it goes



Thank you for the answer. However, that is exactly what I did. But in the resulting image, the labels are cut and i cannot find any option to change this. I tried different scalings and absolute values in the width and height fields...nothing helped.

Hi try with this workflow, that I downloaded from the Examples folder. 

Hope it helps

Best regards


Hi mauuuu5,

thank you for the example workflow. There, the labels are not cut; but only due to the short names. If I use longer column names instead, they are cut again, as you can see in the attached screenshot.


Sure, I could use short labels, but I have so many columns, that I would need abbreviations to avoid mixing them up. I don't find that good in terms of usability. I thought that there must be a setting somewhere to handle this issue.