launch KNIME AP from Eclipse

Dear all, once again I try to install and run the sdk development environment in eclipse w/o success. I found several topics here in the forum but non of them solved my issue. I did the installation according to GitHub - knime/knime-sdk-setup: KNIME Analytics Platform - SDK Setup and everything seemed to be fine. At the end I tried to launch the Knime Platform but always w/o success.

So my environment is as follows:
Eclipse RCP/RAP 2022-12 (4.26.0); Buils 20221201-1913 (I also tried the current version 2023-03)

The error message is:
!ENTRY org.eclipse.osgi 4 0 2023-02-17 14:41:13.309
!MESSAGE Application error
java.lang.RuntimeException: No application id has been found.
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at java.base/jdk.internal.reflect.DirectMethodHandleAccessor.invoke(
at java.base/java.lang.reflect.Method.invoke(
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(
at org.eclipse.equinox.launcher.Main.main(
An error has occurred. See the log file
/Users/dieterg/SynoDrive/Eclipse/ws/knime-core/.metadata/.plugins/org.eclipse.pde.core/KNIME Analytics Platform/1676662872280.log.

I would be very happy if there is s.o. who can help me.
Best regards, Dieter

Hi @dgoebel,

I’m personally haven’t run into this issue before, but the error looks related to this:

The thread is quite long and covers multiple approaches to solve the issue. Maybe one of them works for you?

Kind regards

1 Like

Hi @dgoebel,

two questions:

  • Are you using the correct Java version to launch the AP?
  • Did you maybe modify the target platform file? The editor is a bit buggy and might de-select necessary features. Ensure that the target platform file is in a correct state by running git reset --hard.


1 Like

Hi Marvin, thanks for your help. I already went through this thread but I’ll do it once again. Beside this I have the following questions:
In order to run the example “numberFormatter” do I need the org.knime.core jar file or other jar files? And if so where do I get the files. Because in the java files of the example the import libraries: org.knime.core.* are missin g (underlined red).
Second question: what is the run configuration to start the numberFormatter. Can you provide me a screenshot?
Which release of knime must I activate in Eclipse settings / Plug-in Development as Target Platform? Can I activate my current active release 4.7.1 ?

Dear Gabriel, thanks for your help.
I tried different Java Versions like Java SE 17.0.1 or Java SE 8 (1.8.0. 251). So what is the correct version? What is the purpose of the command “git reset --hard” and where do I execute this command?
Best regards,

Hi Dieter,

To set your target environment to 4.7.1 you need to check out the releases/2022-12 branch in the knime-sdk-setup either in the command line or with the eclipse git client.
Then you need to open either or and set it as the target platform.
To launch a debug AP instance:

NOTE: If the launch configuration is missing, a preconfigured launch configuration (.launch file) is located in the org.knime.sdk.setup project. Right click on the file KNIME Analytics Platform.launch and select Run As → KNIME Analytics Platform.
Make sure you have a Java 17 JVM installed on your system and configured in eclipse.
The git reset command undoes all local changes to the target platform files.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.