Leaving the mount point is not allowed for workflow relative URLs


I'm trying to use the Model Writer node to write to the following URL:


But this gives me the following error:

WARN      Model Writer                       I/O error while checking output location:Leaving the mount point is not allowed for workflow relative URLs: D:\Develop\datamining\data\KNIME-workspace\MyApp\MyApp_Create_Model\..\Models\MyModel.pmml is not in D:\Temp\knime_temp_space_Tim_22144


What I'd like to get to is the following directory structure:

|- MyApp
   |- Models
   |- MyApp_CreateModel
   |- MyApp_RunPrediction
   |- MyApp_ReportSomething
|- MyOtherApp
   |- Models

So the create workflow creates one or more models, that the other workflows can use. I thought the whole point of relative URLs was to be able to do this, but nothing seems to work: I tried knime://knime.workflow and knime://knime.mountpoint. Both keep complaining about some temporary directory not containing the correct folders.

Is this a bug, or am I doing it wrong?


Did you download the workflow from a server into your local workspace? Or did you open it via double-click and then save it to the local workspace?

Double-clicked on the server one and did a Save-As.

I re-opened it from my Local workspace, and now it works. (And now I understand where the temp directory came from :) )

Problem solved, thanks!

Well, you have a workaround but when you "Save As" the workflow should behave as any other local workflow right from the start. We will fix this issue.