Limit CPU usage by executor

Hi KNIME Team,

We had some issues when some workflows using almost all CPU.
I just read in some post of this forum just the possibility to add a minimum requirement of CPU for workflow but not a limitation.

We have 8 Cores, and we have set up the knime.ini file with parameter:
-Dorg.knime.core.maxThreads=7
but this is not also working 100% as not all nodes respect this parameter.

Because of that, I was thinking to install 2 executors on the server in order to use just half of the tokes for each so that then we make sure that one process will not fully overload the server and second executor will be still available for other workflows. However, wile trying to install the additional service we got an error as this cannot be installed.

Could you please help on that?
Or what can we do in order to avoid 100% CPU usage of the server?

BR,
Marc