Linked Metanode wont load when selecting workflow in knime server webfrontend


#1

Hi,

I have a workflow on knime server (4.5 on linux) which contains linked meta nodes. When I select the workflow in the web frontend I get an Load Error with http response code 403. The URL to the meta node displayed in the error message is correct. If I use the URL I can retrieve the meta node manually from my local machine (since I am authenticated I guess), but the server seems not to be authenticated against the rest endpoint.

Is there any specific configuration which has to be set, so that the server can retrieve linked meta nodes? I have the server and executor on the same machine, but I had to set "com.knime.server.canonical-address" in the knime-server.config since the server URL was resolved incorrectly before. 

Cheers

Jan


#2

Hi Jan,

Can you please post the URL of the metanode? (At least the general URL format). Is the metanode template stored on the same server as your KNIME Server? We currently have a ticket open for problems when executing a workflow on server A that uses metanode templates stored on server B. Can you please verify whether this also applies to you?

Cheers,

Roland


#3

Hi Jan & Roland,

I have been receiving a very similar error, that could be related to either of the two problems you're mentioning.

I have been testing WebPortal with two accounts (mine, and a separate one for testing whether it will work for our other users). I'm using the latest version of KNIME Server, 4.6.1.

When I execute a workflow on my account, as the author, it works fine. When I execute on the second, takes a long time to start, and then it fails if there are any linked metanodes that are on the same server -- the error message is "Could not update linked metanodes in [my workflow's name] Server returned HTTP response code". The second user used to have different permissions to the shared metanodes folder, but I updated the folder permissions so now both accounts have read & execute access -- however, the problem did not go away, it still fails to execute with the same error.

IMHO I was very surprised it is even checking to update linked metanodes -- this is usually something I do interactively when editing the workflows, rather than something I'd expected the server to do on ever execution of a workflow. Is there any way to turn that off?

Is there any additional information about this type of issue and workarounds?

 


#5

Hi there, It’s possible to disable checking linked metanodes for updates upon execution on the server. The option in knime-server.config is com.knime.server.executor.update_metanodelinks_on_load=

by default the option is set to false, if it is set to true in your case, setting it to false should solve that issue.


#6

Excellent, thank you Jon! I’ll try that out right away.


#7

Hi Jon – this was exactly what was happening. I don’t recall editing this file before – it’s possible an old version of KNIME server may have had different defaults. Anyways, I’ve changed it to “false” instead and so far in all of my testing the workflows are running great again. Problem solved!


#8

Hi Roland,

the URL displayed is: http://xxx.xxx.xxx.xxx:8080/knime/rest/v4/repository/LEAP/Meta%20Nodes/Preprocessing:data

The xxx.xxxx.xxxx.xxx is the IP of the server (it is not showing 127.0.0.1 or localhost).

I checked and com.knime.server.executor.update_metanodelinks_on_load=true is set. Setting it false resolves the problem. But I guess then I have to update the linked nodes manually if I change any of them.


#9

Hi Jan,

I just tried to reproduce this. I had no problems executing workflows with metanode templates on the WebPortal, and I was also able to update a template when executing.

To investigate this further, can you please send the full error message you see when you try? If there are any entries in the server logs (most likely in localhost.yyyy-MM-dd-log)

Cheers,
Roland