Load throttling

@srauner We want to use load throttling in best possible way as we are getting Socket timeout exception, Read time out execution and Server disconnection. Could you suggest what will be best settings which I should be doing if I want to allow a very good experience to 10 concurrent users. Also the property in red is not clear.

com.knime.server.repository.throttling.min_level
com.knime.server.repository.throttling.keep_alive_interval
com.knime.server.repository.throttling.enable
com.knime.server.repository.throttling.concurrent_fetches

@azadkanswal
When are the socket timeouts happening? Are they getting the errors when trying to log in, deploy workflows, go to WebPortal, …?

Also, you can find all info on those configurations Here.

-Stephen

@azadkanswal,

To add, the min_level parameter says only clients requesting at least that number of nested subfolders are throttled. For instance, a workflow under /Users/srauner/workflows/sync-db, would be at depth 4.

When users connect to the server, they get the repository via deep=true, which will always be throttled according to the min level.

I’m afraid these settings strongly depend on the size of the workflow repository, how frequent changes are made to the repository and on the network connection. We therefore don’t have guidelines for these settings. However, you mostly only need to tweak the concurrent_fetches parameter, unless you are working with programmatic access to the REST API endpoint.

Frequently running into execution timeouts may also be an indication of an overloaded executor.

-Stephen

loading and saving workflows. but once this condition happens it remains for some time