loadAdditionalSettingsFrom doesn't work anymore?

Hello everybody,

I have a strange problem with the “loadAdditionalSettingsFrom” Method.
Somehow this method doesn’t get called anymore. In version 1.3.5 it still works but in version 2.0.1 it doesn’t. I checked the loadSettingsFrom method but this method is still the same, so something else has to be weird. I really don’t know what the matter is. So please … help me :slight_smile:

I use WindowsXP. If you need some additional information just let me know.


Hi Christian,
The loadAddtitionalSettings should be called - no change in the 2.0.1 code there. Unless, the loadSettings method in the component throws an exception. Then the addititional settings method call is omitted.
Do you have a chance to debug this?
Otherwise I would need more details. Maybe best your dialog and model code if it is not too long - and you want to send it.

  • Peter.

I found the problem some days ago.
The reason is a change from java5 to java6. I used an overloaded function loadAdditionalSetttings, with one different parameter (I didn’t see that for a while :wink: ). In knime Version 1.3.5 this method got called, but in 2.0.1 it didn’t. So I changed the parameter and used instead an type cast. So now it works again.


Hello Christian,
Thanks for reporting this problem again. We found out that we have missed to offer the loadAdditionalSettings(NodeSettings,DataTableSpec[]) method in parallel to the new loadAddtionalSettings(NodeSettings,PortObjectSpec[]) method. The PortObjectSpec (resp. PortObject) objects have been introduced with KNIME 2.0 and are used for example inside the NodeModel#configure() (resp. #execute()), NodeDialogPane#loadSettingsFrom(), and DefaultNodeDialogPane#loadAdditionalSettings() methods. Those should only be used when your node implements non-data ports. At the moment you have to live with loadAdditionalSettings(NodeSettings,PortObjectSpec[]) method to overcome the reported bug. Sorry for this hassle.
Regards, Thomas