LOCAL Workspace pointer gone

KNIME seems to have lost the pointer to the local workspace and I don't know how to get it back. 

The workspace is where it always was (a windows box): (Users\name\knime-workspace)

The content is there but in KNIME Explorer it shows a row for LOCAL (Local Workspace) but nothing underneath it. 

If I try to 'save as' it pulls up the LOCAL space but with nothing in it, a '/' as the leading character in the entry box and no ability to save anything entered into that box. 

I presume that there must be a config pointer somewhere but if I try to go to preferences->knime explorer it shows a row for LOCAL but if I hit edit it will only allow me to modify the name of the pointer and not change anything else. 

All help greatly appreciated.

Dominic Ryan

Hi Dominic,

can you try the following_:

go to File -> Switch Workspace and select your workspace? Than restart KNIME Analytics Platform and it should reload your workspace.

If this doesn't work, do you see any error messages in the console when you are restarting?

Best, Iris

 

Thank you for replying. 

I tried this. I only reselected the existing workspace. As soon as I hit enter the platform restarted on its own. Unfortunately nothing changed. The workflows are in that folder and I see them in the project window but because I don't see them in the explorer window I don't know how to modify project variables there and I still can't save etc. 

I grabbed the log file and grep'd out only the restart. I divided that into two. The short one eliminated all the 'found node', ' added new connection', 'found category' and 'loading description' entries in the hope that this might make it easier to see anything useful although there are lots of other routine-seeming messages. The only messages tha seem possibly error related are near the beginning where is says that it could not modify the intro page. The long one is the full restart log.

Even so, perhaps the attached files will help. 

I should add that I uninstalled and reinstalled the platform. However, I didn't delete the workspace folders. Perhaps the next step is to do the reinstall after cleaning out as much as possible. 

If I do that though, what is the process to pull those workflows back in? Do I move the existing folder to some other name and then use the file->Switch workplace method?

Dominic

Added tests

When I create a new workspace the example workflow is listed in that workspace. I can open it and configure at the workflow level as it should work. 

If I then import a workflow from the original workflow archive the example workflow entry vanishes and there are now no entries. I have tried this with several of my prior workflows all with the same result so far. When I import the workflow it offers two items to import and they are always named 'workflow.knime' and 'workflow.svg' despite the different names of the workflow folders. I also tried only importing the .svg file. That did not result in erasing the entry. It left the example workflow and under that workflow.svg. When I went back to reimport the workflow I selected both entries and it then offered to change the name of the 'workflow.svg' entry, which I did, but upon import the entries again vanished. 

Hi Dominic,

this sounds really strange.

Could you do me a favor and make me some screenshots, how your explorer looks like when it is empty? And maybe one of the workflows? You can zip the workflow from the window explorer. A KNIME Workflow is selfcontained, so everything will be inside.

Just, so I don't miss something obvious? When you are importing the workflows, you select "Select root directory"?

Best regards, Iris

PS: you can as well send us this via EMail to our support email adress.

Iris, 

I sent a message through to your support email with the attachements. I also ran a few more tests, including a complete reinstall. I was able to create a new workflow with the wizard and have it appear in knime explorer but importing a workflow caused all local ones to dissappear from explorer even though it stays in the main project window. The workflow that I attempted to import never makes it into the workspace directory either. Manually copying the workflow into the workspace directory does not make it show up either. 

Dominic

Resolution:

I don't know just why the problem happend but I was able to import workflows if I moved them out of the directory that contained them into a new directory. 

All I had done originally was to copy the whole knime-workspace folder to some other location. Anything  I tried to pull from that (or a copy) resulted in the same odd dissappearing list. 

Once I moved each workflow out from that directory I was able to import them with no problem.

Weird, but thanks to Jon Fuller who was able to confirm being able to read in one of the workflows that I had sent him.

Dominic

Perhaps you can assist.   I'm experiencing similar problem.  My Local Workspace no longer shows any of my existing work flows.  When I attempt to import them back in, I select my local workspace and OK button fails to light and I get red message at bottom left of dialog box "Please Select Work Group". 

How can I restore my Local Workspace functionality, to see my workflows?

greg

Update:   Issue resolved.   Found creating new Workspace Folder during startup and importing into it, restored my Local Workspace functionality.    Was able to import all workflows and back online. :)