Looking for the XLS Formatter Nodes

Looking for the XLS Formatter Node. I cannot find it when doing a search. Is this an add one I need.

You need Continental nodes like the one

When you install it, whole Continental package will be installed.


I installed the NodePit but I still don’t see XLS Cell Formatter in my KNIME workspace? Am I missing something?
Thanks for your help,

Obviously, you have (accidentally?) added an invalid “Software Site” to KNIME. Suggest to fix this first: Go to Preferences -> Available Software Sites and remove the entry which contains the URL from the error message.

Afterwards, you can open the “NodePit” view by going to View -> Other, select “NodePit”. In the “NodePit” browser search for the desired node, scroll down to “Installation” and click the little grey download icon. All further steps should then happen automatically.

– Philipp


Thanks Phillip that worked for me
Appreciate your help

1 Like

Thanks for this information.
I got the example from NodePit and installed the Continental extension. But when restaring the the example I’m blocked. I receive again the message that I need to install the extension. The wizard then shows me the Conntinental package again. But I can’t proceed.
So I checked the installed extension and the Continental Package is already in the list !?

Continental Nodes for KNIME | 1.1.1.v202004151921 | com.continental.knime.feature.feature.group | Continental

What I’m doing wrong?

What KNIME version do you use, what’s OS? With 3.7.2 I had installation issues.

@izaychik63 I’m running KNIME 4.1.2 on Windows 10 Enterprise (Build 17134.1401) [64Bit].
Hopefully the 3.7.2 issue has already been solved.

Hi @knimediger,

can you try uninstalling the Continental extension and then re-installing it?
Or ideally try this with a fresh KNIME AP installation?



@gab1one: Sorry I forgot to mention that I already tried the deinstallation and reinstallation of the Continental extension. Was not really successfull :frowning:
I will try to deinstall KNIME.Maybe that will solve the problem.

What I further checked was using the Continental extension on another computer. That worked fine and I was able to fiddle around with the XLS formatter. But that computer is slightly different: Running the same KNIME version but on Win8.1, (Build 9600).

Hi @knimediger,

Please let me know if the problem still persists, it should not be caused by the operating system version, but by the continental plugin itself.


1 Like

That solved the problem with the Continental node. KNime is up and running again and formatting xls sheets is quite nasty but working well.


Hi knimediger
Would you be willing to share your workflow.

Hi there @sgilmour,

you can check workflow examples with Continental nodes here:


1 Like

Hello sgilmour,

the workflow to format xls files is quite simple:
First you define ranges in the xls-sheet (e.g. A1…C55) with one or more xls control table from cell range https://nodepit.com/node/com.continental.knime.xlsformatter.xlscontroltablefromcellrange.XlsControlTableFromCellRangeNodeFactory
In order to define multiple ranges for different formats just use multiple of them and concatenate them.

In the second step you apply some type of format to a cell range (e.g. font attributes nodes, width/height nodes, …). These nodes use as input the cell range and can also be concatenated.
A cell range may be used multiple times (e.g format a1…a99 bold and set the width of a1…a99 to 50).

If all formats are assigned apply the xls-formatter (apply) node https://nodepit.com/node/com.continental.knime.xlsformatter.apply.XlsFormatterApplyNodeFactory to the output of the formats in steps 2. That node reads a xls file and creates another xls file.



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.