loop stops executing

I have a loop within a workflow, several of them, that have been working for more than a year but one of them just stops after one iteration. No error, no message, just stops.
The end node becomes yellows as waiting to star executing but doesn’t execute further.
The end node stays in queued for some time and them becomes yellow.
Whn I isoleted this loop, it works.
The end end node has no dependencies nor do the nodes inside the loop (any external connections)
What am I missing?

this is the workflow:

Hi @manugor,

any chance to have a copy of the workflow and some dummy data to test it? I can’t figure out what can possibly cause the loop to interrupt.

Have a nice day,
Raffaello Barri


@manugor can you check what is ‘leaving’ your loop, and can you also try to select the scope of the loop (right click):

You could try to encapsulate what you do into a component.

Also you might try and provide a fresh log in Debug mode. Also: what version of KNIME are you using?


I had a link leaving the loop from within. Which I removed and then it worked. It’s odd since that flow was like that almost for 2 years. Now I use the new version, 5.2, but it worked in the older versions also.
Thanks a lot.


I removed a link out of the loop and then it worked just fine.
will try to extract that part of the workflow to share
thank you


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.